Project

General

Profile

Bug #27870

Grub Reboot loop after upgrading from 11.1 to 11.1u1

Added by Michael Chianese over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
Sean Fagan
Category:
OS
Target version:
Seen in:
Severity:
Reason for Closing:
Cannot Reproduce
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

Mobo: SuperMicro X10SL7-F
CPU: Celeron G1840
Memory: 2x 4GB ECC 1.35v, 1333Mhz CAS 9
Boot: Sandisk 16gb USB 3.0
Pool1: 3x2tb 5400 SATA drives

ChangeLog Required:
No

Description

Running 11.1 smoothly, and updated to 11.1u1, on boot, it gets to the "Welcome to Grub" banner (no menu), and goes into a reboot loop.

I inserted the 11.1 iso, did an "upgrade" wiping the drive, keeping the config, booted up fine (with some config errors due to the update), did another upgrade to 11.1u1, and did the same reboot loop.

History

#1 Updated by Michael Chianese over 2 years ago

Should be freenas, not truenas...

#2 Updated by Sean Fagan over 2 years ago

I don't know that we have enough information here to diagnose. If the system is rebooting right after "Welcome to Grub!", that either means a configuration issue, a hardware issue, or that grub simply doesn't work on it. Since it booted the ISO, and since you were running FreeNAS before, that most likely suggests a configuration issue or hardware issue.

#3 Updated by Michael Chianese over 2 years ago

It booted from the 11.1 iso, not the 11.1u1 iso. I will attempt to do that...

#4 Updated by Sean Fagan over 2 years ago

Oh, I misunderstood, then: you installed 11.1, then did an upgrade to 11.1-U1.

If you updated via GUI, this could have been a rare (that is, non-reproducible on our end) case where the update goes wonky. In which case, try doing the update from the CLI instead: "freenas-update -v check && freenas-update -v --reboot update".

#5 Updated by Sean Fagan over 2 years ago

  • Status changed from Unscreened to 15
  • Assignee changed from Release Council to Sean Fagan

#6 Updated by Michael Chianese over 2 years ago

Sean Fagan wrote:

Oh, I misunderstood, then: you installed 11.1, then did an upgrade to 11.1-U1.

If you updated via GUI, this could have been a rare (that is, non-reproducible on our end) case where the update goes wonky. In which case, try doing the update from the CLI instead: "freenas-update -v check && freenas-update -v --reboot update".

Updating it directly from the 11.1u1 iso seems to be OK... formatting the boot.

I have another freenas server with the same mobo, i3 processor, more ram, and a sata-dom boot drive... I can see if it's possibly the mobo (although the bios might be a bit different)

#7 Updated by Dru Lavigne over 2 years ago

  • Seen in changed from 11.1-U1 to 11.1-U1

#8 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 2 years ago

  • Status changed from 15 to Blocked
  • Reason for Blocked set to Waiting for feedback

#9 Updated by Michael Chianese over 2 years ago

I have another freenas server with the same mobo, i3 processor, more ram, and a sata-dom boot drive... I can see if it's possibly the mobo (although the bios might be a bit different)

Same mobo (maybe slightly different revision of bios) worked flawlessly...

#10 Updated by Dru Lavigne over 2 years ago

  • Status changed from Blocked to Closed
  • Target version set to N/A
  • Reason for Closing set to Cannot Reproduce
  • Reason for Blocked deleted (Waiting for feedback)

Thanks for the update Michael. Closing out.

Also available in: Atom PDF