Project

General

Profile

Bug #27872

FreeNAS update supports 14 9's!

Added by Michael Dexter almost 3 years ago. Updated almost 3 years ago.

Status:
Done
Priority:
No priority
Assignee:
Xin Tan
Category:
GUI (new)
Severity:
Reason for Closing:
Reason for Blocked:
Other: make note in comments
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

When running update on 11-MASTER-2018010180415, the GUI give a reasonable 8% complete, 8.1%... then randomly ups its precision to numbers like: 8.299999999999999%

Maybe consider one digit of precision?

Associated revisions

Revision 2f4d6774 (diff)
Added by Xin Tan almost 3 years ago

Subject: limit decimals Done: done it Ticket: #27872

Revision bfce9409 (diff)
Added by Xin Tan almost 3 years ago

Subject: limit decimals Done: done it Ticket: #27872

History

#1 Updated by Dru Lavigne almost 3 years ago

  • Assignee changed from Release Council to Erin Clark
  • Target version set to 11.2-BETA1

#2 Updated by Erin Clark almost 3 years ago

  • Assignee changed from Erin Clark to Xin Tan

#3 Updated by Xin Tan almost 3 years ago

where?

#4 Updated by Michael Dexter almost 3 years ago

In the pop-up progress window in the new UI.

#5 Updated by Dru Lavigne almost 3 years ago

  • Status changed from Unscreened to Not Started

#6 Updated by Xin Tan almost 3 years ago

  • Status changed from Not Started to In Progress
  • % Done changed from 0 to 50

#7 Updated by Xin Tan almost 3 years ago

BTW it's a feature, not a bug (Precision and Accuracy).
However, as user requested,
there we go: https://github.com/freenas/webui/pull/327

#8 Updated by Michael Dexter almost 3 years ago

I'm all for precision but few progress bars are very accurate industry-wide. I miss the flying pages for Windows copies though their new "rotary dial" is funny. Just needs the sound of a rotary phone...

#9 Updated by Dru Lavigne almost 3 years ago

  • Reason for Blocked set to Other: make note in comments

Xin: this PR has conflicts.

#10 Updated by Dru Lavigne almost 3 years ago

  • Status changed from In Progress to Done
  • Target version changed from 11.2-BETA1 to Master - FreeNAS Nightlies

Also available in: Atom PDF