Project

General

Profile

Bug #27886

Allow VLAN parent interfaces to be used in VM

Added by Jim Shaw almost 2 years ago. Updated 12 months ago.

Status:
Done
Priority:
No priority
Assignee:
William Grzybowski
Category:
Middleware
Seen in:
Severity:
Medium
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

When trying to assign a Network Interface on a Virtual Machine, ix0 (Intel X520) is not availible in the NIC to attach drop down list. I have tried both adapter types.

FreeNAS-VM-1.jpg (32.2 KB) FreeNAS-VM-1.jpg e82545 Jim Shaw, 01/20/2018 06:44 AM
FreeNAS-NICs-1.jpg (53.6 KB) FreeNAS-NICs-1.jpg Network Interfaces Jim Shaw, 01/20/2018 06:44 AM
FreeNAS-VM-2.jpg (28.9 KB) FreeNAS-VM-2.jpg VirtIO Jim Shaw, 01/20/2018 06:44 AM
ix-vm1.png (16.9 KB) ix-vm1.png Marcelo Araujo, 02/04/2018 10:28 PM
FreeNAS-vLANs.JPG (33.6 KB) FreeNAS-vLANs.JPG Jim Shaw, 02/04/2018 10:45 PM
FreeNAS-mtu.JPG (56.8 KB) FreeNAS-mtu.JPG Jim Shaw, 02/04/2018 10:45 PM
FreeNAS-bge0-1.jpg (26.3 KB) FreeNAS-bge0-1.jpg Jim Shaw, 02/05/2018 12:17 PM
13997
13998
13999
14228
14229
14230
14250

Related issues

Related to FreeNAS - Bug #27885: Allow VM Network Interface to use an MTU over 1500Done2018-01-202018-02-12
Related to FreeNAS - Bug #27996: NIC disappears from VM and Jails listsClosed2018-01-26
Related to FreeNAS - Bug #32901: Adding a VLAN removes NIC bce0 from VM list; new VMs can't use bce0Closed
Related to FreeNAS - Feature #27120: Include open vswitch in freenasClosed
Copied to FreeNAS - Bug #59445: Include VLAN parent as possible choice when assigning a NIC to a VM Done

Associated revisions

Revision e74b2491 (diff)
Added by William Grzybowski 12 months ago

fix(vm): include VLAN parent as possible choice Ticket: #27886

Revision f460c4a0 (diff)
Added by William Grzybowski 12 months ago

fix(vm): include VLAN parent as possible choice Ticket: #27886

Revision 980c7253 (diff)
Added by William Grzybowski 12 months ago

fix(vm): include VLAN parent as possible choice Ticket: #27886 (cherry picked from commit e74b249176c3d9bf2d3c847d6e281eed495223a2)

History

#1 Updated by Dru Lavigne almost 2 years ago

  • Status changed from Unscreened to 15

Jim: please attach screenshots of what you are seeing for both types.

#2 Updated by Dru Lavigne almost 2 years ago

  • Related to Bug #27885: Allow VM Network Interface to use an MTU over 1500 added

#4 Updated by Dru Lavigne almost 2 years ago

  • Status changed from 15 to Unscreened
  • Assignee changed from Release Council to Marcelo Araujo
  • Target version set to 11.1-U2

#5 Updated by Marcelo Araujo almost 2 years ago

  • Status changed from Unscreened to Not Started

#6 Updated by Dru Lavigne almost 2 years ago

  • Related to Bug #27996: NIC disappears from VM and Jails lists added

#7 Avatar?id=13649&size=24x24 Updated by Ben Gadd almost 2 years ago

  • Due date set to 02/12/2018

Due date updated to reflect the code freeze for 11.1U2.

#8 Avatar?id=13649&size=24x24 Updated by Ben Gadd almost 2 years ago

  • Severity set to New

#9 Updated by Marcelo Araujo almost 2 years ago

  • Status changed from Not Started to In Progress

#10 Updated by Marcelo Araujo almost 2 years ago

14228

Is that possible to schedule a teamviewer on your machine?
I can't replicate this issue.

See my screenshot.

#11 Updated by Jim Shaw almost 2 years ago

14229
14230

I wonder if it's something to do with the MTU or vLANs, i've uploaded some more screenshots.

I have a second system (Gen8 Microserver with a x520) that would be better for teamviewer.

Are there any other tests I can run for you?

#12 Updated by Marcelo Araujo almost 2 years ago

Jim Shaw wrote:

I wonder if it's something to do with the MTU or vLANs, i've uploaded some more screenshots.

It could be! Before we could not use network interfaces with Jumbo Frame, I have fixed it already few weeks ago, however it should show the ix interfaces in the select list.

I have a second system (Gen8 Microserver with a x520) that would be better for teamviewer.

Are there any other tests I can run for you?

Maybe you could remove all VLANS associated with one of those 10G interface and check if it shows in the select list.
Although I don't believe that is the problem, but you could give a try.

Best,

#13 Avatar?id=13649&size=24x24 Updated by Ben Gadd almost 2 years ago

  • Category set to Middleware

#14 Updated by Jim Shaw almost 2 years ago

14250

All, I've made some progress testing and will write up my findings. Interestingly this applies to non 10GB interfaces as well, on my HP Microserver i can no longer select BGE0

I've ruled out MTU, It is related to vLANs. Also it took a reboot to take effect.

It seems an Interface that has a native vLAN (no tagging) and tagged vLANs, you are only able to select the tagged vLANs.

The native disappears form the list.

#15 Updated by Marcelo Araujo almost 2 years ago

Jim Shaw wrote:

All, I've made some progress testing and will write up my findings. Interestingly this applies to non 10GB interfaces as well, on my HP Microserver i can no longer select BGE0

I've ruled out MTU, It is related to vLANs. Also it took a reboot to take effect.

It seems an Interface that has a native vLAN (no tagging) and tagged vLANs, you are only able to select the tagged vLANs.

The native disappears form the list.

Hi Jim,

How are you configuring this "native VLAN" ?

Best,

#16 Updated by Jim Shaw almost 2 years ago

The native VLAN is the only VLAN which is not tagged in a trunk, in other words, native VLAN frames are transmitted unchanged.

As a picture tells a thousand words, please see FreeNAS-NICs-1.jpg

In this picture ix0 is the parent interface for van110,vlan250,vlan254,vlan255

#17 Updated by Marcelo Araujo almost 2 years ago

  • Target version changed from 11.1-U2 to 11.2-RC2

Jim Shaw wrote:

The native VLAN is the only VLAN which is not tagged in a trunk, in other words, native VLAN frames are transmitted unchanged.

As a picture tells a thousand words, please see FreeNAS-NICs-1.jpg

In this picture ix0 is the parent interface for van110,vlan250,vlan254,vlan255

I'm inclined to move this ticket target to FreeNAS 11.2, because looks like it is related with networking settings, and I need more time to make a setup and investigating it.
There is nothing that could block this interface to appears in the VM guest list, I really have no idea what could be possible going wrong here.

Best,

#18 Avatar?id=13649&size=24x24 Updated by Ben Gadd almost 2 years ago

  • Due date deleted (02/12/2018)

#19 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 1 year ago

  • Category changed from Middleware to OS

#20 Updated by Dru Lavigne over 1 year ago

  • Related to Bug #32901: Adding a VLAN removes NIC bce0 from VM list; new VMs can't use bce0 added

#21 Updated by Marcelo Araujo over 1 year ago

  • Severity changed from New to Med High

#22 Updated by Marcelo Araujo over 1 year ago

  • Status changed from In Progress to Blocked
  • Reason for Blocked set to Waiting for feedback

Jim,

Do you still have this issue? Or do you figured out any other issue with the network settings?

Best,

#23 Updated by Jim Shaw over 1 year ago

Hello,

Yes the issue is still present in FreeNAS-11.1-U4. As i explained previously, is is the native vlan (untagged parent interface) that cannot be selected on a vLAN trunck.

#24 Updated by Dru Lavigne over 1 year ago

  • Status changed from Blocked to Unscreened
  • Reason for Blocked deleted (Waiting for feedback)

#25 Updated by Marcelo Araujo over 1 year ago

  • Category changed from OS to Middleware
  • Assignee changed from Marcelo Araujo to William Grzybowski
  • Target version changed from 11.2-RC2 to Backlog

Pass along to middleware team.

#26 Updated by William Grzybowski over 1 year ago

  • Status changed from Unscreened to Screened
  • Severity changed from Med High to Medium
  • Needs Doc changed from Yes to No

#28 Updated by Bug Clerk 12 months ago

  • Status changed from Screened to In Progress

#29 Updated by Bug Clerk 12 months ago

  • Status changed from In Progress to Ready for Testing

#30 Updated by Bug Clerk 12 months ago

  • Target version changed from Backlog to 11.3

#31 Updated by Bug Clerk 12 months ago

  • Copied to Bug #59445: Include VLAN parent as possible choice when assigning a NIC to a VM added

#32 Updated by William Grzybowski 12 months ago

  • Subject changed from Unable to assign VM to 10Gig NIC ix0 (Intel X520-DA1) to Allow VLAN parent interfaces to be used in VM
  • Status changed from Ready for Testing to Done
  • Target version changed from 11.3 to Master - FreeNAS Nightlies
  • Needs QA changed from Yes to No
  • Needs Merging changed from Yes to No

This will be tested/documented in the related ticket.

#33 Updated by Alexander Motin 12 months ago

Also available in: Atom PDF