Project

General

Profile

Bug #27893

Storage > Volumes unable to unlock pool

Added by Christian Flämig over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Expected
Assignee:
Peter Southwell
Category:
GUI (new)
Target version:
Seen in:
Severity:
Reason for Closing:
Duplicate
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

The view "Storage > Volumes" doesn't show the volume name and provides no other function than "delete" the volume.

oldUI.png (377 KB) oldUI.png Christian Flämig, 01/21/2018 01:40 AM
newUI.png (484 KB) newUI.png Christian Flämig, 01/21/2018 01:40 AM
newUI_unlocked.png (478 KB) newUI_unlocked.png Christian Flämig, 01/21/2018 01:42 AM
14009
14010
14011

Related issues

Is duplicate of FreeNAS - Feature #27486: Need additional volume actionsDone2018-01-05

History

#1 Updated by Christian Flämig over 2 years ago

  • File debug-sharkoon-20180121093533.txz added
  • Private changed from No to Yes

#2 Updated by Christian Flämig over 2 years ago

  • File newUI.png added

#3 Updated by Christian Flämig over 2 years ago

  • File oldUI.png added

#4 Updated by Christian Flämig over 2 years ago

  • File deleted (newUI.png)

#5 Updated by Christian Flämig over 2 years ago

  • File deleted (oldUI.png)

#6 Updated by Christian Flämig over 2 years ago

14009
14010

Added some screenshots

#7 Updated by Christian Flämig over 2 years ago

14011

After unlocking the volume via the old UI, the new UI shows the content, but still doesn't provide an option to lock the pool.

#8 Updated by Dru Lavigne over 2 years ago

  • Assignee changed from Release Council to Erin Clark
  • Priority changed from No priority to Expected
  • Target version set to 11.2-BETA1

#9 Updated by Erin Clark over 2 years ago

  • Assignee changed from Erin Clark to Peter Southwell

Pete is currently working on encrypted volume stuff so passing to him

#10 Updated by Dru Lavigne over 2 years ago

  • Status changed from Unscreened to Not Started

#11 Updated by Peter Southwell over 2 years ago

  • % Done changed from 0 to 90

found lock wasn't there either.. Which Ive added.

have the unlock totally in place.. but the /api/v1.0/storage/volume/{{id:name}}/unlock takes a required parameter called passphrase. The old UI doens't ask passphrase.. So Im not sure where to get the passphrase to satisfy the api. Going to ask William about where it is.. Sorta hoping.. It's internally stored and the paremeter becomes optional.

#12 Updated by Peter Southwell over 2 years ago

  • Status changed from Not Started to In Progress

have this working save one issue wiht unlock api... I think the passphrase should be optional.. and if not.. Used from geli on the server.. via passphrase file.

#13 Updated by Peter Southwell over 2 years ago

  • Status changed from In Progress to Done
  • % Done changed from 90 to 100

unlock code is there.. pending a UI request for the API.

also.. this is a sorta repeat bug of https://redmine.ixsystems.com/issues/27486

The volume is now displayed as a first class citizen expansion panel.. Where the volumes dataset is included in the expanded panel.

*Note.. I had to add Lock as well.

#14 Updated by Dru Lavigne over 2 years ago

  • Is duplicate of Feature #27486: Need additional volume actions added

#15 Updated by Dru Lavigne over 2 years ago

  • File deleted (debug-sharkoon-20180121093533.txz)

#16 Updated by Dru Lavigne over 2 years ago

  • Status changed from Done to Closed
  • Target version changed from 11.2-BETA1 to N/A
  • Private changed from Yes to No
  • Seen in changed from 11.1-U1 to 11.1-U1
  • Reason for Closing set to Duplicate

Also available in: Atom PDF