Project

General

Profile

Bug #27930

Fix erroneous "Not ran since boot" message when replication task deleted

Added by Chris Simonich over 1 year ago. Updated over 1 year ago.

Status:
Done
Priority:
No priority
Assignee:
Bartosz Prokop
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I deleted a replication task shortly after adding it. Upon deletion all of the remaining replication tasks changed to "Not ran since boot" in the "Last snapshot sent to remote side" column, which was a false status as all of them had run since boot. The replication task added and deleted never ran prior to deletion (by design - it was just a test to see if localhost could be configured as the "remote" system, which it obviously can).

The "Last snapshot sent..." column updates properly when the next snapshot is sent for a given replication task.

System is FreeNAS 11.0-U4 in a VM under ESXi with 4 vCPU and 16GB RAM.

freenas-before-3.jpg (259 KB) freenas-before-3.jpg Dummy replication task to localhost configured Chris Simonich, 01/23/2018 10:55 AM
freenas-after-3.jpg (239 KB) freenas-after-3.jpg After localhost replication task deleted Chris Simonich, 01/23/2018 10:59 AM
14051
14053

History

#1 Updated by Chris Simonich over 1 year ago

Note, just tested on a different system running 11.1-U1. Happens there too.

#2 Updated by Dru Lavigne over 1 year ago

  • Status changed from Unscreened to Not Started
  • Assignee changed from Release Council to Sean Fagan
  • Target version set to 11.1-U2
  • Seen in changed from 11.0-U4 to 11.1-U1
  • Reason for Blocked set to Need additional information

Chris: can you attach a screenshot from the U1 system?

Sean: is this expected behavior?

#3 Updated by Chris Simonich over 1 year ago

14051
14053

Yes, screen shots attached. Note that in this case the "test" replication task did execute as I had to force a snapshot. But the behavior after deletion was the same. To delete I clicked the replication task in the "view Replication Tasks" view and clicked "Delete" at the bottom.

#4 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 1 year ago

  • Due date set to 02/12/2018

Due date updated to reflect the code freeze for 11.1U2.

#5 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 1 year ago

  • Severity set to New

#6 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 1 year ago

  • Assignee changed from Sean Fagan to Bartosz Prokop

#7 Updated by Bartosz Prokop over 1 year ago

  • Status changed from Not Started to In Progress

#8 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 1 year ago

  • Reason for Blocked deleted (Need additional information)

#9 Updated by Bartosz Prokop over 1 year ago

  • Status changed from In Progress to Done

#10 Updated by Dru Lavigne over 1 year ago

  • Subject changed from Replication "Last snapshot sent..." resets to "Not ran since boot" when replication task deleted to Fix erroneous "Not ran since boot" message when replication task deleted
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

Also available in: Atom PDF