Project

General

Profile

Bug #28000

Error message after logging in.

Added by Aaron St. John over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Expected
Assignee:
Damian Szidiropulosz
Category:
GUI (new)
Target version:
Severity:
Reason for Closing:
Duplicate
Reason for Blocked:
Needs QA:
No
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

N/A

ChangeLog Required:
No

Description

After updating my freeNAS mini, I logged in and this error message was displayed. When I clicked close, nothing else I clicked responded.
I had to refresh the page.

See screenshot.

error_message.png (282 KB) error_message.png Aaron St. John, 01/26/2018 08:16 AM
error_msg_log_in.png (70.1 KB) error_msg_log_in.png Aaron St. John, 02/01/2018 07:42 AM
14105
14198

Related issues

Is duplicate of FreeNAS - Bug #27929: Error 22:rrdtool failed: ERROR: opening '/var/db/collectd/rrd/localhost//aggregation-cpu-sum/cpu-user.rrd': No such file or directoryDone2018-01-23

History

#1 Updated by Dru Lavigne over 2 years ago

  • Reason for Blocked set to Need additional information

Aaron: is this still reproducible? If so, on which nightly build?

#2 Updated by Aaron St. John over 2 years ago

14198

Dru Lavigne wrote:

Aaron: is this still reproducible? If so, on which nightly build?

Dru: It seems to only happen after an update. Here is another screenshot. This time I also expanded the "more information" tab and posted it's contents below.
Current build: FreeNAS-11-MASTER-201802010538

Traceback (most recent call last):
File "/usr/local/lib/python3.6/site-packages/middlewared/main.py", line 150, in call_method
result = await self.middleware.call_method(self, message)
File "/usr/local/lib/python3.6/asyncio/coroutines.py", line 109, in next
return self.gen.send(None)
File "/usr/local/lib/python3.6/site-packages/middlewared/main.py", line 904, in call_method
return await self._call(message['method'], serviceobj, methodobj, params, app=app)
File "/usr/local/lib/python3.6/asyncio/coroutines.py", line 109, in next
return self.gen.send(None)
File "/usr/local/lib/python3.6/site-packages/middlewared/main.py", line 872, in _call
return await methodobj(*args)
File "/usr/local/lib/python3.6/asyncio/coroutines.py", line 109, in next
return self.gen.send(None)
File "/usr/local/lib/python3.6/site-packages/middlewared/schema.py", line 502, in nf
return await f(*args, **kwargs)
File "/usr/local/lib/python3.6/asyncio/coroutines.py", line 109, in next
return self.gen.send(None)
File "/usr/local/lib/python3.6/site-packages/middlewared/plugins/stats.py", line 111, in get_data
raise ValueError('rrdtool failed: {}'.format(err.decode()))
ValueError: rrdtool failed: ERROR: opening '/var/db/collectd/rrd/localhost//aggregation-cpu-sum/cpu-interrupt.rrd': No such file or directory

#3 Updated by Dru Lavigne over 2 years ago

  • Assignee changed from Release Council to Erin Clark
  • Target version changed from Master - FreeNAS Nightlies to 11.2-BETA1
  • Reason for Blocked deleted (Need additional information)

#4 Updated by Erin Clark over 2 years ago

I've seen this before but I am unsure how to reproduce it. I suspect it may be a middleware issue (perhaps that file doesn't always get created for some reason?)

#5 Updated by Erin Clark over 2 years ago

  • Assignee changed from Erin Clark to William Grzybowski

I suspect this error message is coming from the middleware side but I don't know specifically how to reproduce it, any ideas William?

#6 Updated by William Grzybowski over 2 years ago

  • Assignee changed from William Grzybowski to Erin Clark

Its possible these datapoints do not exist yet.

I believe you guys should make sure there are aggregate-cpu-sum values before blindly asking for them, does that make sense? stats.get_sources will tell you that

#7 Updated by Bonnie Follweiler over 2 years ago

This is reproducible but it only happens the first time the new GUI is accessed after the Nightlies upgrade

#8 Updated by Erin Clark over 2 years ago

  • Assignee changed from Erin Clark to Damian Szidiropulosz
  • Priority changed from No priority to Expected

I did manage to reproduce this too, it happened to me upon first bootup of a fresh install of 11.1-U1. Damian, this is coming from the dashboard and I know you are currently revamping the dashboard so could you add some checks in to make sure this doesn't pop up when the file isn't generated yet?

#9 Updated by Dru Lavigne over 2 years ago

  • Status changed from Not Started to Closed
  • Target version changed from 11.2-BETA1 to N/A
  • Reason for Closing set to Duplicate

#10 Updated by Dru Lavigne over 2 years ago

  • Is duplicate of Bug #27929: Error 22:rrdtool failed: ERROR: opening '/var/db/collectd/rrd/localhost//aggregation-cpu-sum/cpu-user.rrd': No such file or directory added

Also available in: Atom PDF