Project

General

Profile

Bug #28001

UI Highlights multiple menu options:

Added by Timothy Moore II over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
Erin Clark
Category:
GUI (new)
Target version:
Severity:
Reason for Closing:
Behaves as Intended
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

The New UI menu has an issue displaying which top level option is active. When I click an option with an expandable list of sub-options, then click an option which doesn't, both menu options are highlighted. Clicking between menu options with no expandable list results in proper highlighting.

menu_option_highlight_multiple.png (112 KB) menu_option_highlight_multiple.png Timothy Moore II, 01/26/2018 08:16 AM
14106

History

#1 Updated by Dru Lavigne over 2 years ago

  • Assignee changed from Release Council to Erin Clark
  • Target version set to 11.2-BETA1

#2 Updated by Erin Clark over 2 years ago

I think this may just be the normal behavior of the egret layout we use for our UI panels. Dashboard is highlighted because it is the thing that is currently active and then if you expand a menu item it highlights it until you select something else or expand another menu. Is it leaving more things highlighted than that?

#3 Updated by Timothy Moore II over 2 years ago

  • Status changed from Not Started to Closed
  • Reason for Closing set to Behaves as Intended

Erin Clark wrote:

I think this may just be the normal behavior of the egret layout we use for our UI panels. Dashboard is highlighted because it is the thing that is currently active and then if you expand a menu item it highlights it until you select something else or expand another menu. Is it leaving more things highlighted than that?

Yes you're right - I expected that clicking an expandable menu item would immediately move the highlighting over, but it does behave correctly when I choose an item nested within an expanded menu. I'll go ahead and close this one then, thanks!

#4 Updated by Dru Lavigne over 2 years ago

  • Target version changed from 11.2-BETA1 to N/A

Also available in: Atom PDF