Project

General

Profile

Bug #28028

Unauthorized system reboot

Added by David Scharbach over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
Benno Rice
Category:
OS
Target version:
Seen in:
Severity:
Reason for Closing:
Duplicate
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

My system reboots at random intervals, seemingly only in the middle of the night. I have looked at issues 27671 and 27775 and my system does not seem to be having similar issues. I am not seeing any indication that I am running out of memory in the messages file. The system is spamming that it is "warning" but the light is green.

The system was running stable with 9.10-U6 prior to updating to 11.1. Immediately after updating to 11.1, these reboots began. Prior to V11.1 being installed, uptime would only be affected by user intervention or power failures where the UPS battery level initiated a shutdown. There have been no physical changes made to the system since upgrading to 11.1.

My system runs ESXI 6.5 and the FreeNAS VM boots from SSD physical media. The VM has 8 vCPUs and 128GB of reserved ram.

Any help with this would be greatly appreciated.


Related issues

Is duplicate of FreeNAS - Bug #27514: Break potential recursion involving getnewvnode and zfs_rmnodeDone

History

#1 Updated by David Scharbach over 2 years ago

  • File debug-Zhang-20180128193841.txz added
  • Private changed from No to Yes

#2 Updated by David Scharbach over 2 years ago

  • File messages added

#3 Updated by Dru Lavigne over 2 years ago

  • Status changed from Unscreened to Not Started
  • Assignee changed from Release Council to Alexander Motin
  • Seen in changed from 11.1-U1 to 11.1-U1

#4 Updated by Alexander Motin over 2 years ago

  • Related to Bug #27514: Break potential recursion involving getnewvnode and zfs_rmnode added

#5 Updated by Alexander Motin over 2 years ago

  • Assignee changed from Alexander Motin to Benno Rice

There is no any kernel dumps in the the provided debug, but at least once system was able to save part of the message buffer during the panic, that makes me think it can be a duplication of #27514.

Benno, could you take a closer look on this?

#6 Updated by Dru Lavigne over 2 years ago

  • Target version set to 11.2-RC2

#7 Updated by Benno Rice over 2 years ago

  • Related to deleted (Bug #27514: Break potential recursion involving getnewvnode and zfs_rmnode)

#8 Updated by Benno Rice over 2 years ago

  • Is duplicate of Bug #27514: Break potential recursion involving getnewvnode and zfs_rmnode added

#9 Updated by Dru Lavigne over 2 years ago

  • File deleted (debug-Zhang-20180128193841.txz)

#10 Updated by Dru Lavigne over 2 years ago

  • File deleted (messages)

#11 Updated by Dru Lavigne over 2 years ago

  • Status changed from Not Started to Closed
  • Target version changed from 11.2-RC2 to N/A
  • Private changed from Yes to No
  • Reason for Closing set to Duplicate

David: you will be able to see the other ticket once the dev is finished with the other user's debug.

Also available in: Atom PDF