Project

General

Profile

Bug #28034

Unable to update plex jail

Added by Lorenzo Rosei over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
Release Council
Category:
Middleware
Target version:
Seen in:
Severity:
Reason for Closing:
Not to be fixed
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Hello,

I find myself unable to update the plex jail via the "update button", as it dies with a MiddleWare error.

Request Method:    POST
Request URL:    http://10.0.0.6/plugins/plugin/update/7/
Software Version:    FreeNAS-11.1-RELEASE (dc7d195f4)
Exception Type:    MiddlewareError
Exception Value:    
[MiddlewareError: There was a problem creating the PBI]
Exception Location:    ./freenasUI/middleware/notifier.py in update_pbi, line 2111
Server time:    Mon, 29 Jan 2018 13:06:08 +0100
Traceback

Environment:

Software Version: FreeNAS-11.1-RELEASE (dc7d195f4)
Request Method: POST
Request URL: http://10.0.0.6/plugins/plugin/update/7/

Traceback:
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/exception.py" in inner
  42.             response = get_response(request)
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/base.py" in _legacy_get_response
  249.             response = self._get_response(request)
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/base.py" in _get_response
  178.             response = middleware_method(request, callback, callback_args, callback_kwargs)
File "./freenasUI/freeadmin/middleware.py" in process_view
  162.         return login_required(view_func)(request, *view_args, **view_kwargs)
File "/usr/local/lib/python3.6/site-packages/django/contrib/auth/decorators.py" in _wrapped_view
  23.                 return view_func(request, *args, **kwargs)
File "./freenasUI/plugins/views.py" in plugin_update
  238.         if notifier().update_pbi(plugin=iplugin):
File "./freenasUI/middleware/notifier.py" in update_pbi
  2111.             raise MiddlewareError("There was a problem creating the PBI")

Exception Type: MiddlewareError at /plugins/plugin/update/7/
Exception Value: [MiddlewareError: There was a problem creating the PBI]

Request information
GET
No GET data

POST
Variable    Value
__form_id    'form_str'
FILES
No FILES data

COOKIES
Variable    Value
fntreeSaveStateCookie    'root'
sessionid    'tu9i8oxarchq4xnh2tyg86ytmvrpzyxo'
csrftoken    'mjo71Qew9aODnNG5PqVauvl9wwu4aOmaafQhFjuUD0CDOvE2nczdQRTQhJFx0cVX'
META
Variable    Value

History

#1 Updated by Dru Lavigne over 2 years ago

  • File deleted (debug-susan-20180129131101.tgz)

#2 Updated by Dru Lavigne over 2 years ago

  • Status changed from Unscreened to Closed
  • Target version set to N/A
  • Reason for Closing set to Not to be fixed

Lorenzo: the old plugins system is being transitioned out. In the mean time, if you need a later version of a plugin you can upgrade plugins manually by going into their associated jail. Search the forums for plex upgrade howtos. If you still are stuck on performing the update, create a forum post asking for assistance.

Also available in: Atom PDF