Project

General

Profile

Bug #28118

UPS

Added by Владимир Равковский over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Nice to have
Assignee:
Alexander Motin
Category:
OS
Target version:
Seen in:
Severity:
Reason for Closing:
Not to be fixed
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I'm experiencing trouble connecting an UPS to FreeNAS-9.10.2-U6

Step 1: I connected Ippon Comfo Pro via USB.
Step 2: I got a message GATE ugen5.2: <INNO TECH> at usbus7 I.e. the cable is working and the USB port on the NAS is functioning, right?
Step 3: I set up UPS in Control services via web interface according to the following settings:
UPS mode: master
Identifier: ups
Driver: Ippon ups 2 Back Comfo Pro 600/800 (blazer_usb)
Port: /dev/ugen5.2
ups.conf: empty
upsd.conf: empty
descr: empty
Shutdown mode: low battery
shutdown command: /sbin/shutdown -p now
user: upsmon
pass: ***
Extra users: empty
Remote monitor: yes
Send email status updates: yes
Power off UPS: yes

I push Ok

Step 4 : I start UPS service

Jan 30 20:09:32 GATE ugen5.2: <INNO TECH> at usbus5
Jan 30 20:10:06 GATE notifier: nut not running? (check /var/db/nut/upsd.pid).
Jan 30 20:10:06 GATE notifier: nut_upsmon not running? (check /var/db/nut/upsmon.pid).
Jan 30 20:10:06 GATE notifier: nut_upslog not running? (check /var/db/nut/upslog.pid).
Jan 30 20:10:06 GATE notifier: Cannot 'restart' nut. Set nut_enable to YES in /etc/rc.conf or use 'onerestart' instead of 'restart'.
Jan 30 20:10:06 GATE notifier: Cannot 'restart' nut_upsmon. Set nut_upsmon_enable to YES in /etc/rc.conf or use 'onerestart' instead of 'restart'.
Jan 30 20:10:06 GATE notifier: Cannot 'restart' nut_upslog. Set nut_upslog_enable to YES in /etc/rc.conf or use 'onerestart' instead of 'restart'.
Jan 30 20:10:12 GATE notifier: Supported UPS detected with megatec protocol
Jan 30 20:10:12 GATE notifier: Vendor information unavailable
Jan 30 20:10:12 GATE notifier: No values provided for battery high/low voltages in ups.conf
Jan 30 20:10:12 GATE notifier:
Jan 30 20:10:12 GATE notifier: Using 'guestimation' (low: 10.400000, high: 13.000000)!
Jan 30 20:10:12 GATE notifier: Battery runtime will not be calculated (runtimecal not set)
Jan 30 20:10:12 GATE notifier: Network UPS Tools - UPS driver controller 2.7.3
Jan 30 20:10:12 GATE notifier: Starting nut.
Jan 30 20:10:12 GATE notifier: fopen /var/db/nut/upsd.pid: No such file or directory
Jan 30 20:10:12 GATE notifier: listening on 0.0.0.0 port 3493
Jan 30 20:10:12 GATE notifier: Connected to UPS [ups]: blazer_usb-ups
Jan 30 20:10:12 GATE notifier: /usr/local/etc/nut/cmdvartab not found - disabling descriptions
Jan 30 20:10:12 GATE notifier: Starting nut_upsmon.
Jan 30 20:10:12 GATE notifier: kill: No such process
Jan 30 20:10:12 GATE notifier: UPS: ups (master) (power value 1)
Jan 30 20:10:12 GATE notifier: Using power down flag file /etc/killpower
Jan 30 20:10:12 GATE notifier: Starting nut_upslog.
Jan 30 20:24:23 GATE blazer_usb6033: Permissions problem: Input/output error
Jan 30 20:24:23 GATE upsd6035: Can't connect to UPS [ups] (blazer_usb-ups): No such file or directory
Jan 30 20:24:26 GATE upsmon6050: Poll UPS [ups] failed - Driver not connected
Jan 30 20:24:26 GATE upsmon6050: Communications with UPS ups lost
Jan 30 20:24:31 GATE upsmon6050: Poll UPS [ups] failed - Driver not connected
Jan 30 20:24:36 GATE upsmon6050: Poll UPS [ups] failed - Driver not connected
Jan 30 20:24:41 GATE upsmon6050: Poll UPS [ups] failed - Driver not connected

History

#1 Updated by Владимир Равковский over 2 years ago

  • File debug-GATE-20180201130720.txz added

#2 Updated by Dru Lavigne over 2 years ago

  • Assignee changed from Release Council to Alexander Motin
  • Seen in changed from Unspecified to 9.10.2-U6

#3 Updated by Dru Lavigne over 2 years ago

  • Target version set to 11.2-RC2

#4 Updated by Alexander Motin over 2 years ago

  • Status changed from Not Started to Closed
  • Target version changed from 11.2-RC2 to N/A
  • Reason for Closing set to Not to be fixed

Владимир, could you update to the latest 11.1-U2 release and report if the problem is still there. 9.10.2 will not receive updates any more no matter what.

#5 Updated by Dru Lavigne over 2 years ago

  • File deleted (debug-GATE-20180201130720.txz)

#6 Updated by Dru Lavigne over 2 years ago

  • Private changed from Yes to No

Also available in: Atom PDF