Project

General

Profile

Bug #28165

600MB tmpfs for collectd is too small

Added by Ryan Power over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Nice to have
Assignee:
Release Council
Category:
OS
Target version:
Seen in:
TrueNAS - 11.1-U1
Severity:
Reason for Closing:
Reason for Blocked:
Need additional information
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I was constantly getting out of space messages for /var/db/collectd. It looks like this is mounted as a 600MB tmpfs.

If I unmount it and restart collectd it looks like it needs quite a bit more space:
[root@backup-arap ~]# du -sh /var/db/collectd/
958M /var/db/collectd/

History

#1 Updated by Dru Lavigne over 2 years ago

  • Status changed from Not Started to Closed
  • Target version set to N/A
  • Reason for Closing set to Behaves as Intended

Ryan: you'll want to move your system dataset using the instructions in http://doc.freenas.org/11/system.html#system-dataset.

#2 Updated by Ryan Power over 2 years ago

Moving the dataset doesn't fix the issue. As long as 'reporting database' is unchecked it continues to fail.

#3 Updated by Ryan Power over 2 years ago

  • Reason for Closing deleted (Behaves as Intended)

#4 Updated by Dru Lavigne over 2 years ago

  • Status changed from Closed to Not Started
  • Target version deleted (N/A)
  • Private changed from No to Yes
  • Reason for Blocked set to Need additional information

Ryan: in that case, please attach a debug (System -> Advanced -> Save Debug).

#5 Updated by Dru Lavigne over 2 years ago

  • Target version set to N/A
  • Private changed from Yes to No

Ryan: closing out for now. Please attach a debug once you are able to provide one.

#6 Updated by Dru Lavigne over 2 years ago

  • Status changed from Not Started to Closed

Also available in: Atom PDF