Project

General

Profile

Bug #28227

Issue associated with vm.cards.

Added by Vaibhav Chauhan over 2 years ago. Updated over 2 years ago.

Status:
Done
Priority:
Critical
Assignee:
Damian Szidiropulosz
Category:
GUI (new)
Severity:
Reason for Closing:
Cannot Reproduce
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

1) VNC button issue is now a separate ticket https://redmine.ixsystems.com/issues/28586

2) try creating a new VM and try starting or stopping it, you will see that your screen is filled up with bunch of repeating cards.(see screenshot2)


Related issues

Has duplicate FreeNAS - Bug #26742: [NEW UI/VM] VNC button.Closed2017-11-20
Copied to FreeNAS - Bug #28586: VM cards: Disable VNC button if no WebVNC device existsDone2018-02-06

History

#2 Updated by Anthony Takata over 2 years ago

This can also occur if you try to start a VM and it fails to do so.

#3 Updated by Damian Szidiropulosz over 2 years ago

  • Status changed from Not Started to In Progress

#4 Updated by Damian Szidiropulosz over 2 years ago

  • Copied to Bug #28586: VM cards: Disable VNC button if no WebVNC device exists added

#5 Updated by Damian Szidiropulosz over 2 years ago

  • Subject changed from issues associated with vm.cards. to Issue associated with vm.cards.

This ticket was split into two separate tickets. The bug about the vm card VNC button is now here -> https://redmine.ixsystems.com/issues/28586

#6 Updated by Damian Szidiropulosz over 2 years ago

  • Description updated (diff)

#7 Updated by Damian Szidiropulosz over 2 years ago

  • Description updated (diff)

#8 Updated by Damian Szidiropulosz over 2 years ago

I can't reproduce this with the steps described in ticket and my test system is updated to the latest nightly.
There must be some other variables involved beyond simply creating and starting a new VM.

EDIT: I was able to reproduce this when FreeNAS is running as a VM instance. I made the change in pending PR #408. The fix was to simply not mutate the data and instead, empty out the array before pushing API response data to it.

#9 Updated by Dru Lavigne over 2 years ago

  • Has duplicate Bug #26742: [NEW UI/VM] VNC button. added

#10 Updated by Dru Lavigne over 2 years ago

  • Status changed from In Progress to Closed
  • Target version changed from 11.2-U2 to N/A
  • Reason for Closing set to Cannot Reproduce

#11 Updated by Damian Szidiropulosz over 2 years ago

  • Status changed from Closed to Done

#12 Updated by Damian Szidiropulosz over 2 years ago

  • Reason for Closing deleted (Cannot Reproduce)

#13 Updated by Dru Lavigne over 2 years ago

  • Target version changed from N/A to Master - FreeNAS Nightlies

Also available in: Atom PDF