Project

General

Profile

Bug #28407

Unnecessary fancy widget hunting, extremly annoying, hard to use, inefficient

Added by Mac Lemon over 2 years ago. Updated over 2 years ago.

Status:
Done
Priority:
Nice to have
Assignee:
Lola Yang
Category:
GUI (new)
Seen in:
TrueNAS - 11.1-U1
Severity:
Reason for Closing:
Reason for Blocked:
Need verification
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

There are these “this is a list of some sorts” icon bubbles all over the new UI.
See screenshot.

They serve no purpose other than having an ambiguous icon that, at least to me, looks like “it's a (bulleted) list” but serve no other purpose than to hide other items, like a button to add a new item in the category.

The “list” icon is misleading. There is no list behind that icon.
The UI widget is completely superflous, it's only there to hide the item an admin is searching for, for example the + button to add a thing.
interacting with these items is super annoying and inefficient. I must first use the mouse to target a small item, then wait for the unnecessary spinning animation (which is off center) to reveal one or multiple other items which are even smaller klick targets which I now must try to hit with the mouse again.
Sometimes only to reveal multiple, completely indistinguishable, other items without any label. They require me to even hover over that small item for a second to wait for a tool-tip to appear.

The only solution to this forced interaction:
Get rid of the fancy animated off-center spinning things that hide the actual buttons that make up the wanted actions done by admins all day.

Just show that [+] button all the time. One at the top of any list, one at the bottom, so I have one at my disposal to add an item at any given time.

As a sysadmin I cannot waste time waiting for fancy animations, waiting for tool tips to distinguish ambiguous items. I have to get work done for clients, customers, users, bosses. The UI just has to get out of the way instead of claiming my attention to look at all it's fancy widgets.

History

#1 Updated by Dru Lavigne over 2 years ago

  • Assignee changed from Release Council to Erin Clark
  • Reason for Blocked set to Need verification

Mac: is this reproducible on a nightly? There has been many UI fixes since U1.

#2 Updated by Mac Lemon over 2 years ago

Dru Lavigne wrote:

Mac: is this reproducible on a nightly? There has been many UI fixes since U1.

Sorry, I cannot upgrade my production systems to nightlies. I don't have a for-play system at my disposal at the moment.

#3 Updated by Dru Lavigne over 2 years ago

  • Target version set to 11.2-BETA1

Erin: is there anything to fix here or have these issues already been fixed?

#4 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 2 years ago

  • Due date set to 03/09/2018

#5 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 2 years ago

  • Assignee changed from Erin Clark to Xin Tan

Clean up the saf buttons

"+" sign when there is only a single item

multiple items it will default to a drop down menu

#6 Updated by Xin Tan over 2 years ago

  • Assignee changed from Xin Tan to Damian Szidiropulosz

Damian is much better good at CSS than me

#7 Updated by Erin Clark over 2 years ago

  • Assignee changed from Damian Szidiropulosz to Lola Yang

#8 Updated by Lola Yang over 2 years ago

  • Assignee changed from Lola Yang to Erin Clark

#9 Updated by Lola Yang over 2 years ago

  • Status changed from Not Started to In Progress

#10 Updated by Dru Lavigne over 2 years ago

  • Status changed from In Progress to Done
  • Assignee changed from Erin Clark to Lola Yang
  • Target version changed from 11.2-BETA1 to Master - FreeNAS Nightlies
  • Needs Merging changed from Yes to No

Also available in: Atom PDF