Project

General

Profile

Bug #28408

Help text is hard to read, not left aligned, border missing. (cosmetical, user friendlyness, accessibility)

Added by Mac Lemon over 2 years ago. Updated over 2 years ago.

Status:
Done
Priority:
Nice to have
Assignee:
Erin Clark
Category:
GUI (new)
Seen in:
TrueNAS - 11.1-U1
Severity:
Reason for Closing:
Reason for Blocked:
Need verification
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Help in using the UI is appreciated given the many options in FreeNAS.

Text in help bubbles must be left-aligned (in ltr scripts), have sufficient border around them to distinguish from the background and surrounding UI, and make the text big enough to actually read it.

There is tons of wasteful whitespace in the new UI. (As opposed to helpful whitespace giving structure and optical guidance.) Yet such most text is unnecessarily tiny.

Associated revisions

Revision 23e2b179 (diff)
Added by Erin Clark over 2 years ago

Left align, resize and add a white border to make tooltips more visible Ticket: #28408

Revision 55b1e1fa (diff)
Added by Erin Clark over 2 years ago

On second thought some tooltips look weird if they aren't centered Ticket: #28408

History

#1 Updated by Dru Lavigne over 2 years ago

  • Assignee changed from Release Council to Erin Clark
  • Reason for Blocked set to Need verification

Mac: is this reproducible on a nightly? There has been many UI fixes since U1.

#2 Updated by Mac Lemon over 2 years ago

Dru Lavigne wrote:

Mac: is this reproducible on a nightly? There has been many UI fixes since U1.

Sorry, I cannot upgrade my production systems to nightlies. I don't have a for-play system at my disposal at the moment.

#3 Updated by Dru Lavigne over 2 years ago

  • Target version set to 11.2-BETA1

Erin: is there anything to fix here or have these issues already been fixed?

#4 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 2 years ago

  • Due date set to 03/09/2018

#5 Updated by Erin Clark over 2 years ago

What resolution of screen and browser are you using (maybe take a screenshot to help illustrate?)

#6 Updated by Erin Clark over 2 years ago

  • Assignee changed from Erin Clark to Lola Yang

#7 Updated by Erin Clark over 2 years ago

  • Status changed from Not Started to In Progress

#8 Updated by Erin Clark over 2 years ago

  • Assignee changed from Lola Yang to Erin Clark
  • Target version changed from 11.2-BETA1 to 11.2-RC2

I made the text a little larger and added a white border around the tooltips to make them stand out on darker themes, left align looks a little weird on some tooltips so we will have to rethink that one later.

#9 Updated by Dru Lavigne over 2 years ago

  • Status changed from In Progress to Done
  • Target version changed from 11.2-RC2 to Master - FreeNAS Nightlies

#10 Updated by Dru Lavigne over 2 years ago

  • Needs Merging changed from Yes to No

Also available in: Atom PDF