Project

General

Profile

Bug #28433

Cannot create Jails that use DHCP using the new GUI

Added by Mac Lemon over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Nice to have
Assignee:
Lola Yang
Category:
GUI (new)
Target version:
Seen in:
Severity:
Reason for Closing:
Cannot Reproduce
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

When I need a jail with FreeBSD 11.1 I must use the new GUI since the .mtree for warden jails with the working GUI has not been updated and it's won't-fix. :-(

When creating a new jail in the new-GUI I'd expect a jail to default to DHCP for IPv4 and SLAAC for IPv6.
Jails actually default to no-networking at all. Having that possibility is welcome, but a rare use-case.

Trying to make a jail use DHCP to obtail an IPv4 address on the local network does not work by putting DHCP in the “basic settings” section where it says: IPv4 Address, but one must scroll down and page to the custom properties section and tick the DHCP box there.
Klick Save at the very bottom and restart the jail.
Wait, there is no way to restart the jail. This was a single klick in the working GUI. Now one must klick on the three dots to bring up the menu, klick stop, wait for the jail to actually stop, klick the three dots again, klick start and the jail does not start at all anymore.
There is no indication of anything happening.

Investigating on the command line on the host with
iocage list -l
indicates that the jail is stopped and should be using DHCP.
trying to start it with
iocage start JAILNAME

reports an iocage errror:

JAILNAME requires bpf=yes!

Go back to the GUI to check if that setting is exposed anywhere, and after some digging and klicking through all the folding sections I can find a checkbox named bpf. Instead of just using “find” in my browser to quickly jump to that setting like I could do with an efficient list that just show ALL the settings at once I'm forced to click multiple times.

The bfp box is already ticked. In fact it was ticked from the beginning.
So I untick the box, tick it again, save and try to start the jail. (This requires twice as many clicks in the new GUI as in the working GUI.)
Jail doesn't start.
investigating with iocage on the command line again still tells me, that JAILNAME requires bpf=yes!
So the new GUI is misreporting the state of bpf.

I'm setting bfp via
iocage set bpf=yes JAILNAME

Now I can start the jail.
The GUI does not report the IPv4 address of that jail, but only a blank cell. (There's already a bug open on that matter.)

Having to jump from working GUI to new-GUI to command line to new-GUI and through multiple burning hoops just to get a jail on the network is inefficient and frustrating.
Please update that .mtree file so we can use 11.1 jails with the working GUI, because the current workflow necessary to get a networked jail with software that is not 6months+ outdated is not funny.
Thanks!

History

#1 Updated by Dru Lavigne over 2 years ago

  • Assignee changed from Release Council to Erin Clark
  • Target version set to 11.2-BETA1
  • Seen in changed from 11.1-U1 to 11.1-U1

#2 Updated by Erin Clark over 2 years ago

  • Assignee changed from Erin Clark to Xin Tan

#3 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 2 years ago

  • Due date set to 03/09/2018

#4 Updated by Xin Tan over 2 years ago

  • Assignee changed from Xin Tan to Lola Yang

give this back to lola since she's back also worked on jails for most of the part, she knows all about it.

#5 Updated by Lola Yang over 2 years ago

Hi Mac,

Restart jail is not applicable for now (confirmed by Brandon); the bpf error is already fixed, please try the latest nightly. Thanks.

#6 Updated by Dru Lavigne over 2 years ago

  • Status changed from Not Started to Closed
  • Target version changed from 11.2-BETA1 to N/A
  • Reason for Closing set to Cannot Reproduce

Also available in: Atom PDF