Project

General

Profile

Bug #28434

Setting ZFS Quota doesn't work in the new GUI

Added by Mac Lemon over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Nice to have
Assignee:
Erin Clark
Category:
GUI (new)
Target version:
Seen in:
TrueNAS - 11.1-U1
Severity:
Reason for Closing:
Duplicate
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

When trying to set a quota for a Dataset in the new GUI it complains about not-setting anything else.
Dialog cannot be dismissed.
In addition, the dialog gives information what is expected by the form checker, which is welcome. But, the form checker refuses the suggestion of 0 which was prepopulated in the form, AND is suggested by the form checker and this was also the way it was before when using the working GUI which shows the exact same 0 for not setting a specific property.

Workaround:
Admin must log out, and back in with the working GUI to set a quota.
Admin must login over SSH and set the quota using the command line.


Related issues

Is duplicate of FreeNAS - Bug #28435: Setting ZFS Quota doesn't work in the new GUIDone2018-02-112018-03-09

History

#1 Updated by Dru Lavigne over 2 years ago

  • Assignee changed from Release Council to Erin Clark
  • Target version set to 11.2-BETA1

#2 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 2 years ago

  • Due date set to 03/09/2018

#3 Updated by Erin Clark over 2 years ago

  • Is duplicate of Bug #28435: Setting ZFS Quota doesn't work in the new GUI added

#4 Updated by Erin Clark over 2 years ago

  • Status changed from Not Started to Closed
  • Reason for Closing set to Duplicate

#5 Updated by Dru Lavigne over 2 years ago

  • Target version changed from 11.2-BETA1 to N/A

Also available in: Atom PDF