Project

General

Profile

Bug #28441

Adding auxiliary parameters breaks snmpd.

Added by Ian Cartwright over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
No priority
Assignee:
Vladimir Vinogradenko
Category:
Middleware
Target version:
Seen in:
Severity:
Reason for Closing:
Duplicate
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Just upgrade to 11.1-U1 at the request of Dru (see bug 28431). Noticed that cacti isn't updating stats on the box. I have a bunch of "extend" parameters to run scripts when certain OIDs are queried. If I take those statements out of the "Auxiliary Parameters" then /etc/local/snmpd.conf is generated correctly. If I leave them in I get a broken snmpd.conf. The community string is missing (though that option is filled in in the GUI) and the sysLocation is set to one of my auxiliary parameters...

Broken snmpd.conf:

agentAddress udp:161,udp6:161,unix:/var/run/snmpd.sock
sysLocation extend hstemp /mnt/tank/home/vol1/unix/cacti/homeseer/hs-temp-stats
sysContact unknown@localhost
sysDescr Hardware: amd64 Intel(R) Xeon(R) CPU E5-1620 v3 @ 3.50GHz running at 3500 Software: FreeBSD 11.1-STABLE (revision 199506)

master agentx
rocommunity "" default


Related issues

Is duplicate of FreeNAS - Bug #27334: Pass SNMP Auxiliary parameters values to running configurationDone2017-12-192018-02-12
Is duplicate of FreeNAS - Bug #27871: Pass SNMP Auxiliary parameters values to running configurationClosed2018-01-19

History

#1 Updated by Dru Lavigne over 1 year ago

  • Private changed from No to Yes

Thanks, Ian. It would be useful to attach a debug from the U1 system to this ticket.

#2 Updated by Ian Cartwright over 1 year ago

  • File debug-nas1-20180212120146.tgz added

Attached debug as requested.

#3 Updated by Dru Lavigne over 1 year ago

  • Category set to Middleware
  • Assignee changed from Release Council to Vladimir Vinogradenko
  • Target version set to 11.2-RC2

#4 Updated by Vladimir Vinogradenko over 1 year ago

  • Status changed from Not Started to Closed
  • Reason for Closing set to Duplicate

Ian, this issue will be resolved in 11.1-U2 which will be released soon.

#5 Updated by Dru Lavigne over 1 year ago

  • Is duplicate of Bug #27334: Pass SNMP Auxiliary parameters values to running configuration added

#6 Updated by Dru Lavigne over 1 year ago

  • File deleted (debug-nas1-20180212120146.tgz)

#7 Updated by Dru Lavigne over 1 year ago

  • Target version changed from 11.2-RC2 to N/A
  • Private changed from Yes to No

#8 Updated by Vladimir Vinogradenko over 1 year ago

  • Is duplicate of Bug #27871: Pass SNMP Auxiliary parameters values to running configuration added

#9 Updated by Ian Cartwright over 1 year ago

Oops. Shoulda searched first. Sorry about that.

Also available in: Atom PDF