Project

General

Profile

Bug #28476

Avatar?id=14398&size=22x22

Boot environments deleted after upgrade......

Added by Graham Bird over 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Expected
Assignee:
Kris Moore
Category:
OS
Target version:
Seen in:
Severity:
Reason for Closing:
Not Applicable
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

We upgraded from 9-10-2-U6 to 11-1-U1 (details here: https://forums.freenas.org/index.php?threads/upgraded-9-10-2-u6-to-11-1-u1-periodic-crashes.61358/#post-436415) and was, following recommendations, bugged here: (https://redmine.ixsystems.com/issues/28249#change-164553).

We decided to roll back to the previous version with which we had no problems (9-10-2-U6), and if our understanding of the docs is correct, should be able to do that by choosing a previous boot environment in GRUB at system boot.

The old environments are listed in Freenas (screenshot), but in GRUB only the single option for the current environment is available. It seems that all previous environments have been deleted.

We upgraded by selecting the new train in Freenas and did NOT upgrade the pool flags.


Related issues

Related to FreeNAS - Bug #28133: Fix error that prevented proper deletion of boot environmentDone2018-02-012018-02-14

History

#1 Updated by Dru Lavigne over 1 year ago

  • Related to Bug #28133: Fix error that prevented proper deletion of boot environment added

#2 Updated by Dru Lavigne over 1 year ago

  • Private changed from No to Yes

Graham: please attach a debug (System -> Advanced -> Save Debug) to assist the dev in determining the cause of this issue.

#3 Updated by Dru Lavigne over 1 year ago

  • Category set to Middleware
  • Assignee changed from Release Council to William Grzybowski
  • Target version set to 11.1-U2

#4 Updated by Dru Lavigne over 1 year ago

Actually, taking a closer look, what happens when you select "Boot Envrionment Menu" from the GRUB menu? Are your boot environments not listed in the sub-menu?

#5 Updated by Sean Fagan over 1 year ago

Also, could you attach the file /boot/grub/grub.cfg please?

#6 Updated by Graham Bird over 1 year ago

I'll take a look. It will be tomorrow before I'm back in the office.

Cheers

#7 Updated by Graham Bird over 1 year ago

  • File debug-Guardian-20180207101527.tar added

Debug log (from previous bug report #28249) added.

#8 Updated by Graham Bird over 1 year ago

  • File grub.cfg added

Grub config file, as requested:

#9 Avatar?id=14398&size=24x24 Updated by Kris Moore over 1 year ago

  • Assignee changed from William Grzybowski to Kris Moore
  • Target version changed from 11.1-U2 to 11.2-RC2

Aside from having a lot of BE's (15+) the config looks fine. I'm unsure if there's some upper limits on how many can be loaded into GRUB's memory.

Can you go into the FreeNAS BE's menu and clean up a couple of the old stale ones? Once thats done, reboot and in the GRUB menu try going to the 2nd option to select old BEs. Does anything flash on the screen like an error real quick, or does it list anything at all? Could we get a couple pictures of that screen?

#10 Updated by Graham Bird over 1 year ago

14381
14382
14383
14384

Ok, I updated the available list of BEs, see screenshot. However, when booting as you will see from the attached photo, only the OLD environments appear in the list.

Odd!

When I first tried to delete a single old BE I got an error, I have included those screenshots for completeness.

Cheers

#11 Updated by Graham Bird over 1 year ago

Did my last email provide what is required?

#12 Updated by Graham Bird over 1 year ago

14404

Checking the system this morning (related to the spontaneous reboots), I noticed that the version after a restart is 9-10-2-U6 (see attached).

This despite the fact that that BE did NOT appear in the Grub menu. In fact, that option had been selected in the System > Boot menu for a while, it was just ignored until now.

Hope that helps.........

Cheers

#13 Updated by William Grzybowski about 1 year ago

  • Category changed from Middleware to OS

#14 Avatar?id=14398&size=24x24 Updated by Kris Moore about 1 year ago

  • Status changed from Not Started to Closed
  • Reason for Closing set to Not Applicable

This looks like an issue generating the GRUB config. We've replaced it with a different boot-loader in 11.2, so this is more than likely fixed now.

#15 Updated by Dru Lavigne about 1 year ago

  • File deleted (debug-Guardian-20180207101527.tar)

#16 Updated by Dru Lavigne about 1 year ago

  • File deleted (grub.cfg)

#17 Updated by Dru Lavigne about 1 year ago

  • Target version changed from 11.2-RC2 to N/A
  • Private changed from Yes to No

Also available in: Atom PDF