Project

General

Profile

Bug #28489

Discontinuous or bouncing graph in ARC Hit Ratio Reporting

Added by Stefan Schroepfer about 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
Waqar Ahmed
Category:
Services
Target version:
Seen in:
Severity:
Low
Reason for Closing:
Behaves as Intended
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Since I updated my system to 11.1 (*) the graph in ARC Hit Ratio Reporting is very discontinuous or bouncing. Without further investigation of the underlying data I'm not able to tell which of these two words describes the situation better.

Hardware: Supermicro A1SAi-2750F, 32 GB ECC unbuffered (4x Kingston KVR16LSE11/8KF), main pool: 2x WD Red (mirrored), two further pools (also 2-way mirrors), boot media: 2x SanDisk X300s 2.5" SATA 64GB (mirrored) on Syba SI-PEX40063

Usage: Backup target for three Windows 10 PCs (daily, Veeam Free Edition), backup source and target (3 times per day, ZFS replication), file server usage via SMB. No plugins, no jails.

Some example graphs are gives in the attached files, some further example can be seen in
https://forums.freenas.org/index.php?threads/arc-hit-ratio-all-over-the-place-after-upgrading-memory.61527/
Other forums members seem to have the problem as well.

Just a rough guess: The problem described here might be related to
Bug #25966 Update module that reports ARC Hit Ratio

(*) I'm pretty sure that the problem started with 11.1-RELEASE. Unfortunately all reporting history got inaccessible during update to 11.1-RELEASE (which I had running only for a few days) and then to 11.1-U1 as well. My system is running now 11.1-U1 for about 26 days. The attached screenshots were created running 11.1-U1.

ZFS_ARC_Hour_cr.png (50.4 KB) ZFS_ARC_Hour_cr.png FreeNAS 11.1-U1, Timespan 1 hour Stefan Schroepfer, 02/13/2018 02:11 PM
ZFS_ARC_Day_cr.png (48.2 KB) ZFS_ARC_Day_cr.png FreeNAS 11.1-U1, Timespan 1 day Stefan Schroepfer, 02/13/2018 02:11 PM
ZFS_ARC_Week_cr.png (50.1 KB) ZFS_ARC_Week_cr.png FreeNAS 11.1-U1, Timespan 1 week Stefan Schroepfer, 02/13/2018 02:12 PM
ZFS_ARC_Month_cr.png (50.1 KB) ZFS_ARC_Month_cr.png FreeNAS 11.1-U1, Timespan 1 month Stefan Schroepfer, 02/13/2018 02:12 PM
14360
14361
14362
14363

Related issues

Related to FreeNAS - Bug #25966: Update module that reports ARC Hit RatioResolved2017-09-25

History

#1 Updated by Stefan Schroepfer about 3 years ago

  • Description updated (diff)

#2 Updated by Dru Lavigne about 3 years ago

  • Related to Bug #25966: Update module that reports ARC Hit Ratio added

#3 Updated by Dru Lavigne about 3 years ago

  • Private changed from No to Yes
  • Reason for Blocked set to Need additional information

Please also attach a debug to this ticket (System -> Advanced -> Save Debug) to help the dev in identifying the cause.

#4 Updated by Stefan Schroepfer about 3 years ago

  • File debug-blunzn-20180213233030.tgz added
  • Private changed from Yes to No
  • Reason for Blocked deleted (Need additional information)

Adding Debug file. Please let me know if further information is required.

#5 Updated by Stefan Schroepfer about 3 years ago

  • Private changed from No to Yes

#6 Updated by Dru Lavigne about 3 years ago

  • Category changed from Middleware to OS
  • Assignee changed from Release Council to John Hixson
  • Target version set to 11.2-RC2

John: passing to you as you last worked on this module.

#7 Updated by John Hixson almost 3 years ago

  • Severity set to Low

#8 Updated by John Hixson over 2 years ago

  • Category changed from OS to Services

#9 Updated by Dru Lavigne over 2 years ago

  • Target version changed from 11.2-RC2 to 11.2-BETA3

#10 Updated by John Hixson over 2 years ago

  • Target version changed from 11.2-BETA3 to 11.2-U2

#11 Updated by Dru Lavigne over 2 years ago

  • Assignee changed from John Hixson to William Grzybowski

#12 Updated by William Grzybowski over 2 years ago

  • Assignee changed from William Grzybowski to Waqar Ahmed

#13 Updated by Waqar Ahmed over 2 years ago

  • Status changed from Not Started to In Progress

#14 Updated by Waqar Ahmed over 2 years ago

  • Status changed from In Progress to Closed
  • Target version changed from 11.2-U2 to N/A
  • Reason for Closing set to Behaves as Intended
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

The issue is fixed in the latest 11.2 RC-1 Release. Please feel free to let us know otherwise.

#15 Updated by Dru Lavigne over 2 years ago

  • File deleted (debug-blunzn-20180213233030.tgz)

#16 Updated by Dru Lavigne over 2 years ago

  • Private changed from Yes to No

Also available in: Atom PDF