Project

General

Profile

Bug #28544

Merge in compressed ARC patches

Added by Bill Sorenson about 1 year ago. Updated 12 months ago.

Status:
Done
Priority:
Important
Assignee:
Dru Lavigne
Category:
OS
Target version:
Seen in:
Severity:
Medium
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

The latest release of ZFS on Linux includes a patch related to one of the changes in compressed ARC support. The issue results in a notable decline in ARC hit rate.

The details of the ZoL patch can be found here: https://github.com/zfsonlinux/zfs/pull/6989

It is my option from testing my own hack import of the patch into FreeBSD 11-STABLE and 11.1-R that this issue also affects FreeBSD 11.1+ and FreeNAS. On my own system running FreeBSD 11.1 (with this patch) my ARC hit rate went from ~35% to ~97% after a few days. The system serves as a file share, runs several jails and also ran a few buildworlds on the machine in that time. I'd like someone to validate my findings if possible.

I'm not sure how soon OpenZFS/FreeBSD are to port that over, FreeNAS is usually one of the first to pull in the cross-pollination of ZFS enhancements that I've seen.

-Bill S

Associated revisions

Revision a8c26e0e (diff)
Added by Dru Lavigne 12 months ago

Mention OS and ZFS improvements.
Ticket: #28544
Ticket: #23893

History

#1 Updated by Dru Lavigne about 1 year ago

  • Assignee changed from Release Council to Alexander Motin

Alexander: what are your thoughts on this one?

#2 Updated by Alexander Motin about 1 year ago

  • Category set to OS
  • Priority changed from No priority to Expected
  • Target version set to 11.2-BETA1
  • Severity set to Medium

Description in the ZoL PR looks significant. I'll take a deeper look on it. Unfortunately I don't see it in Illumos/OpenZFS, that complicates things, but at least the patch is not very invasive.

#3 Avatar?id=13649&size=24x24 Updated by Ben Gadd about 1 year ago

  • Due date set to 03/09/2018

#4 Updated by Dru Lavigne about 1 year ago

  • Target version changed from 11.2-BETA1 to 11.2-RC2

#5 Updated by Alexander Motin about 1 year ago

  • Priority changed from Expected to Important

We tried that patch, and while it does improve some synthetic tests, we haven't found it to produce significant difference in more realistic tests. The reason is that very small amount of data are kept decompressed in DMU cache, and so affected by this issue. It should probably be fixed, but may be not a huge deal. It should be proposed to OpenZFS for inclusion.

#6 Updated by Alexander Motin about 1 year ago

  • Status changed from Not Started to In Progress

Since dbuf cache size increased recently (will be in FN 11.2), effect of this patch should grow more significant. I've pushed the pull request to OpenZFS.

#7 Updated by Alexander Motin about 1 year ago

  • Status changed from In Progress to Done

I've just merged that patch into freenas/11-stable branch (further 11.2) together with other changes.

#8 Updated by Dru Lavigne about 1 year ago

  • Subject changed from Compressed ARC performance regression to Merge in compressed ARC patches
  • Target version changed from 11.2-RC2 to 11.2-BETA1
  • Needs Doc changed from No to Yes

#9 Updated by Dru Lavigne 12 months ago

  • Needs Doc changed from Yes to No

#10 Updated by Eric Loewenthal 12 months ago

  • Assignee changed from Alexander Motin to Dru Lavigne

Dru: I think the OpenZFS blurb should read just "device removal" instead of "SLOG/L2ARC device removal", or something along those lines. SLOG and L2ARC have been removable for a very long time, the new feature is for vdev removal (only works with mirrors, according to the man page).

Also available in: Atom PDF