Project

General

Profile

Bug #28573

Fix default permissions on /etc/services

Added by Brandon Applegate over 1 year ago. Updated about 1 year ago.

Status:
Done
Priority:
Expected
Assignee:
Vladimir Vinogradenko
Category:
Middleware
Target version:
Seen in:
Severity:
Low Medium
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Forum post:

https://forums.freenas.org/index.php?threads/11-1-etc-services-permissions.61686/

I just upgraded from 9.10 to 11.1 (U1) - and noticed that the 'ntpq' utility was failing with:

servname not supported for ai_socktype

Using truss - I see that it can't open /etc/services because:

[vom@freenas ~]$ ls la /etc/services
-rw------
1 root wheel 86187 Feb 16 22:29 /etc/services

Is there a reason /etc/services is 600 ? I don't think I've ever seen this before. Thanks for any info.

Associated revisions

Revision 96a667d8 (diff)
Added by Vladimir Vinogradenko over 1 year ago

fix(ix-inetd): chmod 644 /etc/services (it was created with mktemp, default permissions were 600)

Ticket: #28573

Revision 9106ccc6 (diff)
Added by Vladimir Vinogradenko over 1 year ago

fix(ix-inetd): chmod 644 /etc/services (it was created with mktemp, default permissions were 600)

Ticket: #28573

Revision 49615c6b (diff)
Added by Vladimir Vinogradenko over 1 year ago

fix(ix-inetd): chmod 644 /etc/services (it was created with mktemp, default permissions were 600)

Ticket: #28573

History

#1 Updated by Brandon Applegate over 1 year ago

  • File debug-freenas-20180218010804.txz added
  • Private changed from No to Yes

#2 Updated by Dru Lavigne over 1 year ago

  • Category changed from OS to Middleware
  • Assignee changed from Release Council to William Grzybowski
  • Target version set to 11.2-RC2
  • Seen in changed from 11.1-U1 to 11.1-U1

William: please load balance (or pass to OS/Services team if it is more appropriate there).

#3 Updated by William Grzybowski over 1 year ago

  • Assignee changed from William Grzybowski to Vladimir Vinogradenko
  • Priority changed from Nice to have to Expected
  • Severity set to Low Medium

Vladimir, this seems to be a fallout from the latest ix-inetd changes when there is no extra config.

#4 Updated by Vladimir Vinogradenko over 1 year ago

  • Status changed from Not Started to Done

#5 Updated by Dru Lavigne over 1 year ago

  • File deleted (debug-freenas-20180218010804.txz)

#6 Updated by Dru Lavigne over 1 year ago

  • Subject changed from /etc/services permissions 600 ? to Fix default permissions on /etc/services
  • Target version changed from 11.2-RC2 to 11.2-BETA1
  • Private changed from Yes to No
  • Needs Doc changed from Yes to No

#7 Updated by William Grzybowski over 1 year ago

  • Status changed from Done to In Progress

We still need to merge the PRs

#8 Updated by William Grzybowski over 1 year ago

  • Status changed from In Progress to Done

#9 Updated by Dru Lavigne over 1 year ago

  • Needs Merging changed from Yes to No

#10 Updated by Dru Lavigne about 1 year ago

  • Status changed from Done to Ready for Testing

#11 Avatar?id=55038&size=24x24 Updated by Zackary Welch about 1 year ago

  • Needs QA changed from Yes to No

I can confirm the permissions for /etc/services are now 644 on 11.2.

#12 Updated by Dru Lavigne about 1 year ago

  • Status changed from Ready for Testing to Done

Also available in: Atom PDF