Project

General

Profile

Bug #28574

Unauthorized Reboots

Added by David Green over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Nice to have
Assignee:
Benno Rice
Category:
OS
Target version:
Seen in:
Severity:
Reason for Closing:
Duplicate
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I am experiencing random reboots for no explained reason. It appears to vary in frequency between 2-5 days generally. Is this a known bug?


Related issues

Is duplicate of FreeNAS - Bug #27514: Break potential recursion involving getnewvnode and zfs_rmnodeDone

History

#1 Updated by David Green over 3 years ago

  • File debug-freenas-20180218014000.txz added
  • Private changed from No to Yes

#2 Updated by Timur Bakeyev over 3 years ago

The box is actually crashing in the kernel with double fault.

#3 Updated by Dru Lavigne over 3 years ago

  • Assignee changed from Release Council to Alexander Motin
  • Target version set to 11.2-RC2
  • Seen in changed from 11.1-U1 to 11.1-U1

#4 Updated by Benno Rice over 3 years ago

  • Assignee changed from Alexander Motin to Benno Rice

This is another case of the zfs_zget/zfs_rmnode recursion.

#5 Updated by Benno Rice over 3 years ago

  • Is duplicate of Bug #27514: Break potential recursion involving getnewvnode and zfs_rmnode added

#6 Updated by Dru Lavigne over 3 years ago

  • File deleted (debug-freenas-20180218014000.txz)

#7 Updated by Dru Lavigne over 3 years ago

  • Status changed from Not Started to Closed
  • Target version changed from 11.2-RC2 to N/A
  • Private changed from Yes to No
  • Reason for Closing set to Duplicate

David: you will be able to see the other ticket once the dev is finished with that user's debug.

Also available in: Atom PDF