Project

General

Profile

Bug #28593

Fix middlewared debug not starting

Added by Brandon Schneider about 1 year ago. Updated 10 months ago.

Status:
Done
Priority:
Important
Assignee:
Brandon Schneider
Category:
OS
Target version:
Seen in:
TrueNAS - 11.1-U1
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Related projects 1 project

Description

Currently it breaks the initialization of middlewared, and consequently takes down ha systems when used.


Related issues

Related to FreeNAS - Bug #28680: Actually restart when middlewared is started in the foregoundDone2018-02-22
Copied to FreeNAS - Bug #35392: Fix middlewared debug not starting which takes down HAClosed

Associated revisions

Revision fa36ed02 (diff)
Added by Brandon Schneider about 1 year ago

fix(rc): middlewared debug not starting

This now runs it in foreground mode in a tmux session that gets killed upon stopping.

Ticket: #28593

Revision 8b97efc5 (diff)
Added by Brandon Schneider about 1 year ago

fix(rc): middlewared debug not starting (#873)

  • fix(rc): middlewared debug not starting

This now runs it in foreground mode in a tmux session that gets killed upon stopping.

Ticket: #28593

  • Address William's review

This is a cleaner implementation, by modifying main.py to always create a pidfile.

History

#1 Updated by William Grzybowski about 1 year ago

  • Related to Bug #28680: Actually restart when middlewared is started in the foregound added

#2 Avatar?id=13649&size=24x24 Updated by Ben Gadd about 1 year ago

  • Due date set to 03/12/2018

#3 Avatar?id=13649&size=24x24 Updated by Ben Gadd about 1 year ago

  • Due date changed from 03/12/2018 to 03/09/2018

#4 Updated by Brandon Schneider about 1 year ago

  • Status changed from In Progress to Done

#5 Updated by Dru Lavigne about 1 year ago

  • Subject changed from middlewared_debug rc flag does not work to Fix middlewared debug not starting
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#6 Updated by Dru Lavigne 12 months ago

  • Status changed from Done to Ready for Testing

#7 Updated by Bonnie Follweiler 10 months ago

  • Project changed from FreeNAS to TrueNAS
  • Category changed from OS to OS
  • Severity set to New
  • Migration Needed set to No
  • Hide from ChangeLog set to No
  • Support Department Priority set to 0

This works in FreeNAS-11.2-INTERNAL4
It needs to be tested in a TrueNAS HA system

#8 Avatar?id=13649&size=24x24 Updated by Ben Gadd 10 months ago

  • Target version changed from 11.2-BETA1 to TrueNAS 11.2

#9 Updated by Dru Lavigne 10 months ago

  • Project changed from TrueNAS to FreeNAS
  • Category changed from OS to OS
  • Target version changed from TrueNAS 11.2 to 11.2-BETA1
  • Migration Needed deleted (No)
  • Hide from ChangeLog deleted (No)
  • Support Department Priority deleted (0)

#11 Updated by Bonnie Follweiler 10 months ago

  • Copied to Bug #35392: Fix middlewared debug not starting which takes down HA added

#12 Updated by Bonnie Follweiler 10 months ago

  • Status changed from Ready for Testing to Passed Testing

#13 Updated by Dru Lavigne 10 months ago

  • Status changed from Passed Testing to Done

#14 Updated by Dru Lavigne 10 months ago

  • Needs QA changed from Yes to No

Also available in: Atom PDF