Project

General

Profile

Bug #28623

First load of beta UI gets error: " Error 201:[ENOMETHOD] Method "summary" not found in "network.general""

Added by Ben Hartshorne almost 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
No priority
Assignee:
Release Council
Category:
GUI (new)
Target version:
Seen in:
Severity:
Reason for Closing:
Duplicate
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Just did an upgrade from 9.3 to 11. First login, I clicked the "try out the beta UI". It gave me one hint popup, then threw an error. Happy to provide more detail - not sure what would be useful.

Error 201:[ENOMETHOD] Method "summary" not found in "network.general"

Traceback (most recent call last):
File "/usr/local/lib/python3.6/site-packages/middlewared/main.py", line 893, in method_lookup
serviceobj = self.get_service(service)
File "/usr/local/lib/python3.6/site-packages/middlewared/main.py", line 822, in get_service
return self.
_services[name]
KeyError: 'network.general'

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File "/usr/local/lib/python3.6/site-packages/middlewared/main.py", line 150, in call_method
result = await self.middleware.call_method(self, message)
File "/usr/local/lib/python3.6/asyncio/coroutines.py", line 109, in next
return self.gen.send(None)
File "/usr/local/lib/python3.6/site-packages/middlewared/main.py", line 902, in call_method
serviceobj, methodobj = self._method_lookup(message['method'])
File "/usr/local/lib/python3.6/site-packages/middlewared/main.py", line 896, in _method_lookup
raise CallError(f'Method "{method_name}" not found in "{service}"', CallError.ENOMETHOD)
middlewared.service_exception.CallError: [ENOMETHOD] Method "summary" not found in "network.general"


Related issues

Is duplicate of FreeNAS - Bug #28622: 11.1.-U2 new GUI errorClosed2018-02-20

History

#1 Updated by Michael Dexter almost 3 years ago

I am experiencing this too and it has also been reported as https://redmine.ixsystems.com/issues/28622

#2 Updated by Dru Lavigne almost 3 years ago

  • Category set to GUI (new)
  • Status changed from Not Started to Closed
  • Target version set to N/A
  • Reason for Closing set to Duplicate

#3 Updated by Dru Lavigne almost 3 years ago

  • Is duplicate of Bug #26822: A error on System -> Advanced Page added

#4 Updated by Dru Lavigne almost 3 years ago

  • Is duplicate of deleted (Bug #26822: A error on System -> Advanced Page)

#5 Updated by Dru Lavigne almost 3 years ago

  • Is duplicate of Bug #28622: 11.1.-U2 new GUI error added

Also available in: Atom PDF