Project

General

Profile

Bug #28663

HTTP Basic auth prompts, typically in Safari (FreeNAS-11-MASTER-201802211301 )

Added by David Discher over 3 years ago. Updated over 3 years ago.

Status:
Done
Priority:
No priority
Assignee:
-
Category:
GUI (new)
Seen in:
Severity:
Med High
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

It looks like the New UI is loading data via API, and this API: /api/v1.0/storage/replication/

On the main landing page after login is prompting for HTTP Basic Auth.

This might be every single XHR request going back to the API that is having issues.

History

#1 Updated by David Discher over 3 years ago

  • Subject changed from HTTP Basic auth prompts, typically in Safari to HTTP Basic auth prompts, typically in Safari (FreeNAS-11-MASTER-201802211301 )
  • Seen in changed from 11.1-U2 to N/A

Happening in FreeNAS-11-MASTER-201802211301

#2 Updated by David Discher over 3 years ago

A few of the XHR calls are lacking trailing slashes, and resulting in 301 redirects.

The holy web says that this may be related to the safari issue :

https://stackoverflow.com/questions/35684933/https-requests-with-authorization-not-working-via-safari

#3 Updated by Dru Lavigne over 3 years ago

  • Assignee changed from Release Council to Anonymous
  • Target version set to 11.2-BETA1

#4 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 3 years ago

  • Due date set to 03/09/2018

#5 Updated by Anonymous over 3 years ago

  • Status changed from Not Started to Done

This should be fixed in nightlies now

#6 Updated by Dru Lavigne over 3 years ago

  • Target version changed from 11.2-BETA1 to Master - FreeNAS Nightlies

Also available in: Atom PDF