Project

General

Profile

Feature #28778

Enable VMs to use lagg bonds or other kinds of interfaces

Added by BloodyIron - over 2 years ago. Updated almost 2 years ago.

Status:
Done
Priority:
No priority
Assignee:
William Grzybowski
Category:
Middleware
Estimated time:
Severity:
Medium
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

Description

Right now I don't see a way to configure a VM to use a lagg (LACP) interface, if one is available. I can only see a way to configure a VM to use a single interface.

I would really like it if we could configure a VM to use a LAGG, or other interfaces. Namely in my case as I want to use this for cache purposes, which would benefit from lots of bandwidth and naturally all the sessions would span the multiple interfaces.

Please? :)

Tested in 11.1-U2


Related issues

Has duplicate FreeNAS - Bug #33603: Problem with VM on vLAN on laggClosed
Has duplicate FreeNAS - Bug #32901: Adding a VLAN removes NIC bce0 from VM list; new VMs can't use bce0Closed
Copied to FreeNAS - Feature #59544: Add lagg support to VMsDone

Associated revisions

Revision 91f5a27f (diff)
Added by William Grzybowski almost 2 years ago

fix(gui): regenerate VM NIC choices Ticket: #28778

Revision 0fb2e2bc (diff)
Added by William Grzybowski almost 2 years ago

fix(gui): regenerate VM NIC choices Ticket: #28778

Revision 482df9fa (diff)
Added by William Grzybowski almost 2 years ago

fix(gui): regenerate VM NIC choices Ticket: #28778

Revision a3e3833f (diff)
Added by William Grzybowski almost 2 years ago

fix(gui): regenerate VM NIC choices Ticket: #28778

History

#1 Updated by Dru Lavigne over 2 years ago

  • Category set to OS
  • Assignee changed from Release Council to Marcelo Araujo
  • Target version set to 11.2-RC2

#2 Updated by Marcelo Araujo over 2 years ago

  • Severity set to Medium

#3 Updated by Dru Lavigne over 2 years ago

  • Has duplicate Bug #33603: Problem with VM on vLAN on lagg added

#4 Updated by Marcelo Araujo over 2 years ago

  • Status changed from Not Started to Screened
  • Target version changed from 11.2-RC2 to 11.4

Bump to 11.4, perhaps I can bring it to 11.3.

#5 Updated by Marcelo Araujo over 2 years ago

  • Category changed from OS to Middleware
  • Status changed from Screened to Unscreened
  • Assignee changed from Marcelo Araujo to William Grzybowski
  • Target version changed from 11.4 to N/A

Forward to middleware team!

#6 Updated by William Grzybowski over 2 years ago

  • Target version changed from N/A to Backlog

#7 Updated by William Grzybowski over 2 years ago

  • Status changed from Unscreened to Screened

#8 Avatar?id=25780&size=24x24 Updated by Ned Devine about 2 years ago

I would love this. Here's some limited investigation when I was looking into it earlier this year:

https://forums.freenas.org/index.php?threads/losing-packets-between-lagg-and-vlan.62097/

#10 Updated by Dru Lavigne almost 2 years ago

  • Has duplicate Bug #32901: Adding a VLAN removes NIC bce0 from VM list; new VMs can't use bce0 added

#11 Updated by Bug Clerk almost 2 years ago

  • Status changed from Screened to In Progress

#12 Updated by William Grzybowski almost 2 years ago

  • Target version changed from Backlog to 11.3

Workaround: reboot freenas after configuring interfaces (for legacy UI)

#13 Updated by Bug Clerk almost 2 years ago

  • Status changed from In Progress to Ready for Testing

#14 Updated by Bug Clerk almost 2 years ago

#15 Updated by William Grzybowski almost 2 years ago

  • Status changed from Ready for Testing to Done
  • Target version changed from 11.3 to Master - FreeNAS Nightlies
  • Needs QA changed from Yes to No
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

This will be tested in related ticket.

Also available in: Atom PDF