Project

General

Profile

Bug #28804

Update API docs for SMART tests

Added by Lola Yang about 1 year ago. Updated about 1 year ago.

Status:
Done
Priority:
Important
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Severity:
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

About SMART Test Task API, in the doc http://api.freenas.org/resources/tasks.html#id11

smarttest_disks (string) – list of ids of “storage/disk” resource

but the storage/disAPIpi doesn't return id.


Related issues

Related to FreeNAS - Bug #27510: SMART Tasks Will not saveClosed2017-12-292018-03-09

Associated revisions

Revision a47d38ef (diff)
Added by William Grzybowski about 1 year ago

fix(api): smart tests take disk_identifier not id

Ticket: #28804

Revision dddaa88c (diff)
Added by William Grzybowski about 1 year ago

fix(api): smart tests take disk_identifier not id

Ticket: #28804

Revision 79b60ccd (diff)
Added by William Grzybowski about 1 year ago

fix(api): smart tests take disk_identifier not id

Ticket: #28804

History

#1 Updated by Lola Yang about 1 year ago

  • Related to Bug #27510: SMART Tasks Will not save added

#2 Updated by William Grzybowski about 1 year ago

  • Status changed from Not Started to Blocked
  • Reason for Blocked set to Waiting for feedback

The documentation seems wrong.

Can you try using the `disk_identifier` field instead of the `id` and let me know if that works so I can update the docs?

Thanks

#3 Avatar?id=13649&size=24x24 Updated by Ben Gadd about 1 year ago

  • Due date set to 03/09/2018

#4 Updated by Lola Yang about 1 year ago

  • Status changed from Blocked to Closed

William Grzybowski wrote:

The documentation seems wrong.

Can you try using the `disk_identifier` field instead of the `id` and let me know if that works so I can update the docs?

Thanks

yes. I used 'disk_identifier' and it works before.
I retest it on version FreeNAS-11-MASTER-201802232214. It looks like it works again. I will close this ticket. Thanks.

#5 Updated by Dru Lavigne about 1 year ago

  • Target version changed from 11.2-BETA1 to N/A
  • Reason for Closing set to Cannot Reproduce
  • Reason for Blocked deleted (Waiting for feedback)

#6 Updated by William Grzybowski about 1 year ago

  • Status changed from Closed to In Progress
  • Target version changed from N/A to 11.2-BETA1
  • Reason for Closing deleted (Cannot Reproduce)
  • Needs QA changed from Yes to No
  • Needs Merging changed from Yes to No

I will update the docs since its obviously wrong.

#7 Updated by William Grzybowski about 1 year ago

  • Status changed from In Progress to Done

#8 Updated by Dru Lavigne about 1 year ago

  • Subject changed from No id returned from "storage/disk" API to Update API docs for SMART tests
  • Needs Doc changed from Yes to No

Also available in: Atom PDF