Project

General

Profile

Bug #29072

Unable to attach boot drive of same type / size

Added by Clay Mitchell over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
No priority
Assignee:
Vladimir Vinogradenko
Category:
Middleware
Target version:
Seen in:
Severity:
Reason for Closing:
Duplicate
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I've been trying to attach a new boot disk, and am getting an error status stating that

The device called USB Flash Memory does not have enough space to mirror

The thing is that it is a brand new drive of the exact same sort as the existing one. They came out of the same pack.

Full Error Message:

Request Method:    POST
Request URL:    http://mediasource.local/system/bootenv/pool/attach/?label=da1p2
Software Version:    FreeNAS-11.1-U2 (c636d1f4b)
Exception Type:    MiddlewareError
Exception Value:    
[MiddlewareError: [EFAULT] The device called USB Flash Memory (14.45 GB, 30310400 sectors does not have enough space to mirror the old device USB Flash Memory (14.45 GB, 30310400 sectors). Please use a larger device.]
Exception Location:    ./freenasUI/system/forms.py in done, line 298
Server time:    Sun, 4 Mar 2018 12:47:45 -0500
Traceback

Environment:

Software Version: FreeNAS-11.1-U2 (c636d1f4b)
Request Method: POST
Request URL: http://mediasource.local/system/bootenv/pool/attach/?label=da1p2

Traceback:
File "./freenasUI/system/forms.py" in done
  296.                 c.call('boot.attach', devname, {'expand': self.cleaned_data['expand']}, job=True)
File "/usr/local/lib/python3.6/site-packages/middlewared/client/client.py" in call
  417.                 raise ClientException(job['error'], trace=job['exception'])
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/exception.py" in inner
  42.             response = get_response(request)
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/base.py" in _legacy_get_response
  249.             response = self._get_response(request)
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/base.py" in _get_response
  178.             response = middleware_method(request, callback, callback_args, callback_kwargs)
File "./freenasUI/freeadmin/middleware.py" in process_view
  162.         return login_required(view_func)(request, *view_args, **view_kwargs)
File "/usr/local/lib/python3.6/site-packages/django/contrib/auth/decorators.py" in _wrapped_view
  23.                 return view_func(request, *args, **kwargs)
File "./freenasUI/system/views.py" in bootenv_pool_attach
  497.             form.done()
File "./freenasUI/system/forms.py" in done
  298.                 raise MiddlewareError(str(e))
File "./freenasUI/system/forms.py" in done
  298.                 raise MiddlewareError(str(e))

Exception Type: MiddlewareError at /system/bootenv/pool/attach/
Exception Value: [MiddlewareError: [EFAULT] The device called USB Flash Memory (14.45 GB, 30310400 sectors does not have enough space to mirror the old device USB Flash Memory (14.45 GB, 30310400 sectors). Please use a larger device.]

Request information
GET
Variable    Value
label    'da1p2'
POST
Variable    Value
__all__    ''
attach_disk    'da0'
__form_id    'form_BootEnvPoolAttachForm'
FILES
No FILES data

COOKIES
Variable    Value
csrftoken    '********'
sessionid    '93e94igw8glp5g4gc1ichk5m5b0kwz3s'
fntreeSaveStateCookie    'root%2Croot%2F10%2Croot%2F81%2F82%2Croot%2F81%2Croot%2F49%2Croot%2F82%2Croot%2F82%2F168%2Croot%2F49%2F62%2Croot%2F10%2F20%2Croot%2F49%2F56%2Croot%2F49%2F53%2Croot%2F1%2Croot%2F1%2F6'
META
Variable    Value

Related issues

Related to FreeNAS - Bug #27834: Fix the attachment of boot mirror devicesDone2018-01-162018-02-12
Is duplicate of FreeNAS - Bug #29086: Display more information when mirroring boot device fails due to target device size being too smallDone

History

#1 Updated by Eric Loewenthal over 3 years ago

Note that the interesting part is that they report the same size in sectors (30310400).

#2 Updated by Dru Lavigne over 3 years ago

  • Related to Bug #27834: Fix the attachment of boot mirror devices added

#3 Updated by Dru Lavigne over 3 years ago

  • Assignee changed from Release Council to Vladimir Vinogradenko
  • Target version set to 11.2-RC2

#4 Updated by Vladimir Vinogradenko over 3 years ago

  • Status changed from Unscreened to Closed
  • Reason for Closing set to Duplicate

#5 Updated by Vladimir Vinogradenko over 3 years ago

#6 Updated by Dru Lavigne over 3 years ago

  • Is duplicate of Bug #29086: Display more information when mirroring boot device fails due to target device size being too small added

#7 Updated by Dru Lavigne over 3 years ago

  • Target version changed from 11.2-RC2 to N/A

Also available in: Atom PDF