Project

General

Profile

Feature #29094

Add field for MTU config on network interfaces to legacy UI

Added by Nick Wolff over 2 years ago. Updated over 1 year ago.

Status:
Passed Testing
Priority:
Important
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Estimated time:
Severity:
Med High
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
Yes
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

Description

Currently Mtu is set by hand in the option section and isn't verified/well documented. This should be fixed in both GUI

Constraints:
  • Validate values from 1280 - 9216
  • Update from old style to new on next network config
  • MTU for lagg should be abstracted to be set at top level not members. * Middleware needs to first apply this mtu to all members and then build lagg from members * This will allow proper lagg setup with out multiple steps * Any changing of value will require complete destruction and rebuild of lagg and should be alerted * Current alert maybe enough but we may want more specific warning of impact on changing lagg on a RUNNING lag

OS limitation discussion:
https://lists.freebsd.org/pipermail/freebsd-hackers/2015-February/046993.html


Related issues

Related to FreeNAS - Feature #25092: Allow changing MTU of lagg interfaceDone
Related to FreeNAS - Umbrella #50841: Network Interfaces Management RewriteDone
Copied to FreeNAS - Feature #71809: Add field for MTU config on network interfaces to new UIClosed

History

#3 Updated by Alexander Motin over 2 years ago

  • Related to Feature #25092: Allow changing MTU of lagg interface added

#4 Updated by Dru Lavigne over 2 years ago

  • Target version changed from 11.1-U3 to 11.3

#5 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 2 years ago

  • Target version changed from 11.3 to Backlog

#6 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 2 years ago

  • Severity set to New

#7 Updated by Erin Clark over 2 years ago

  • Severity changed from New to Med High

#8 Updated by Dru Lavigne about 2 years ago

  • Target version changed from Backlog to 11.3

#9 Updated by Dru Lavigne almost 2 years ago

#10 Updated by William Grzybowski almost 2 years ago

  • Category changed from GUI (new) to Middleware
  • Status changed from Not Started to Ready for Testing
  • Assignee changed from Erin Clark to William Grzybowski

This is available starting from legacy UI in 11.3 (as part of https://github.com/freenas/freenas/pull/1613 -- Umbrella ticket)

#11 Updated by Dru Lavigne over 1 year ago

  • Target version changed from 11.3 to 11.3-BETA1

#12 Updated by Dru Lavigne over 1 year ago

  • Copied to Feature #71809: Add field for MTU config on network interfaces to new UI added

#13 Updated by Dru Lavigne over 1 year ago

  • Subject changed from Add field for MTU config on network interfaces to Add field for MTU config on network interfaces to legacy UI
  • Needs Merging changed from Yes to No

#17 Avatar?id=55038&size=24x24 Updated by Zackary Welch over 1 year ago

I can see this option in the legacy UI. However, values outside '1280 - 9216' are accepted. How do I test that the MTU config is functional?

#18 Updated by William Grzybowski over 1 year ago

Zackary Welch wrote:

I can see this option in the legacy UI. However, values outside '1280 - 9216' are accepted. How do I test that the MTU config is functional?

values outside is by design.

do "ifconfig xxx" in shell and verify mtu value

#19 Avatar?id=55038&size=24x24 Updated by Zackary Welch over 1 year ago

  • Status changed from Ready for Testing to Passed Testing

Thanks. I see the MTU changed in 'ifconfig', so this passes testing.

#20 Updated by Dru Lavigne over 1 year ago

  • Needs QA changed from Yes to No

Also available in: Atom PDF