Project

General

Profile

Bug #29106

Remove note from Guide and tooltip that incorrectly stated encrypted pools could not be used for the system dataset

Added by Bonnie Follweiler over 2 years ago. Updated about 2 years ago.

Status:
Done
Priority:
No priority
Assignee:
Aaron St. John
Category:
Documentation
Target version:
Seen in:
TrueNAS - TrueNAS 11.1-U2
Severity:
Low
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I am on TrueNAS-11.1-U2-RC20 on the QA X10
In the User Guide:
under Fig. 4.6.1 System Dataset Screen there is a Note that states "Encrypted volumes are not displayed in the System dataset pool drop-down menu."
As you can see by my screenshot, the encrypted volume is in the drop down list

Screen Shot 2018-03-05 at 3.56.27 PM.png (28.4 KB) Screen Shot 2018-03-05 at 3.56.27 PM.png Bonnie Follweiler, 03/05/2018 12:56 PM
Screen Shot 2018-03-05 at 3.53.22 PM.png (23.4 KB) Screen Shot 2018-03-05 at 3.53.22 PM.png Bonnie Follweiler, 03/05/2018 12:57 PM
Screen Shot 2018-03-05 at 3.52.49 PM.png (52.1 KB) Screen Shot 2018-03-05 at 3.52.49 PM.png Bonnie Follweiler, 03/05/2018 12:57 PM
Screen Shot 2018-03-05 at 3.56.14 PM.png (35.6 KB) Screen Shot 2018-03-05 at 3.56.14 PM.png Bonnie Follweiler, 03/05/2018 12:58 PM
encrypted_import.jpg (1.59 MB) encrypted_import.jpg Bonnie Follweiler, 08/01/2018 01:22 PM
system_dataset_page.png (123 KB) system_dataset_page.png Aaron St. John, 08/22/2018 10:04 AM
14748
14750
14752
14754
23380
25145

Related issues

Related to FreeNAS - Bug #37606: Add missing and updated tooltips or fieldsDone
Related to FreeNAS - Feature #29269: Can System Dataset live on an Encrypted Pool?Closed
Related to FreeNAS - Bug #83235: Do not allow a password to be set on an encrypted pool if it is set as the "System Dataset"Ready for Testing

History

#1 Updated by Bonnie Follweiler over 2 years ago

  • Subject changed from Encrypted Volumes are displayed in the displayed in the System dataset pool drop-down menu to Encrypted Volumes are displayed in the System dataset pool drop-down menu

#2 Updated by Dru Lavigne over 2 years ago

  • Category changed from GUI to Middleware
  • Assignee changed from Release Council to William Grzybowski
  • Target version changed from N/A to TrueNAS 11.1-U3

#3 Updated by William Grzybowski over 2 years ago

  • Assignee changed from William Grzybowski to Bonnie Follweiler

That note is wrong. Encrypted volumes never stopped showing in that field. Only locked ones are hidden.

#4 Updated by Dru Lavigne over 2 years ago

  • Project changed from TrueNAS to FreeNAS
  • Category deleted (Middleware)
  • Assignee changed from Bonnie Follweiler to Warren Block
  • Target version changed from TrueNAS 11.1-U3 to 11.2-BETA1
  • Migration Needed deleted (No)
  • Hide from ChangeLog deleted (No)
  • Support Department Priority deleted (0)

#5 Updated by Bonnie Follweiler over 2 years ago

So I have a question: Should encrypted volumes show in that popup? What happens if they set the System dataset pool to an encrypted volume and it gets locked?

#6 Updated by Dru Lavigne over 2 years ago

  • Category set to Documentation
  • Target version changed from 11.2-BETA1 to 11.2-RC2

#7 Updated by Dru Lavigne over 2 years ago

  • Severity set to Low

#8 Updated by Dru Lavigne about 2 years ago

  • Target version changed from 11.2-RC2 to 11.2-BETA3

#10 Updated by Aaron St. John about 2 years ago

In the new UI an encrypted, locked pool shows up in the "System Dataset Pool" drop down (found in System > Dataset). It also allows the user to select this locked pool and save it as the system dataset pool.

Sidenote: In the legacy UI a locked pool does not show up in the drop down menu.

Is this a bug?

#11 Updated by Bonnie Follweiler about 2 years ago

23380

So, if the first pool created is an encrypted pool FreeNAS automatically makes it the system dataset, which is the expected behavior from what I understand.
However, I did a clean install of FreeNAS 11.2-Beta2, then imported the encrypted/locked volume that I had detached. On my console it showed a repetitive error message (screenshot provided). I ran "ls -l /var/db/collected/rrd" and it returned that "there is no such file or directory". I rebooted the system and everything was was fine.

My question is would it be feasible to ensure that any encrypted volume, locked or unlocked, doesn't get selected automatically as the system dataset. The customer could go in there and change it to an encrypted volume if that's what they want?

#12 Updated by Warren Block about 2 years ago

  • Category changed from Documentation to Middleware
  • Status changed from Not Started to Unscreened
  • Assignee changed from Warren Block to William Grzybowski

Docs will update the User Guide to reflect that encrypted pools are shown in the pool list. Reassigning to middleware, because the user really A) needs to know that the system dataset is being put on an encrypted pool, and B) needs to be able to choose a different dataset if one is available.

#13 Updated by William Grzybowski about 2 years ago

  • Category changed from Middleware to Documentation
  • Assignee changed from William Grzybowski to Warren Block

Warren Block wrote:

Docs will update the User Guide to reflect that encrypted pools are shown in the pool list. Reassigning to middleware, because the user really A) needs to know that the system dataset is being put on an encrypted pool, and B) needs to be able to choose a different dataset if one is available.

I dont understand either of your requests.

For A) thats a UI thing AFAIK
For B) what dataset are you talking about? User selects a pool. All pools are available to be chosen.

#14 Updated by Aaron St. John about 2 years ago

#15 Updated by Aaron St. John about 2 years ago

  • Needs Doc changed from Yes to No

#16 Updated by Dru Lavigne about 2 years ago

  • Status changed from Unscreened to In Progress
  • Assignee changed from Warren Block to Aaron St. John

#17 Updated by Dru Lavigne about 2 years ago

  • Subject changed from Encrypted Volumes are displayed in the System dataset pool drop-down menu to Remove note from Guide that incorrectly stated encrypted pools could not be used for the system dataset
  • Status changed from In Progress to Done
  • Needs QA changed from Yes to No
  • Needs Merging changed from Yes to No

#18 Updated by Aaron St. John about 2 years ago

Master PR for the tool tip: https://github.com/freenas/webui/pull/1154

#19 Updated by Dru Lavigne about 2 years ago

  • Related to Bug #37606: Add missing and updated tooltips or fields added

#20 Updated by Dru Lavigne about 2 years ago

  • Status changed from Done to In Progress
  • Needs Merging changed from No to Yes

#21 Updated by Dru Lavigne about 2 years ago

  • Subject changed from Remove note from Guide that incorrectly stated encrypted pools could not be used for the system dataset to Remove note from Guide and tooltip that incorrectly stated encrypted pools could not be used for the system dataset
  • Status changed from In Progress to Ready for Testing
  • Needs QA changed from No to Yes
  • Needs Merging changed from Yes to No

#22 Updated by Aaron St. John about 2 years ago

25145

Tested on FreeNAS-11.2-MASTER-201808220903

See screenshot of the tooltip with correct text.

#23 Updated by Dru Lavigne about 2 years ago

  • Status changed from Passed Testing to Done

#24 Updated by Warren Block about 2 years ago

  • Related to Feature #29269: Can System Dataset live on an Encrypted Pool? added

#25 Updated by Bonnie Follweiler over 1 year ago

  • Related to Bug #83235: Do not allow a password to be set on an encrypted pool if it is set as the "System Dataset" added

Also available in: Atom PDF