Project

General

Profile

Bug #29429

Jails/Add and Jails/Edit forms RCTL Limits section not functional

Added by Timothy Moore II over 3 years ago. Updated over 3 years ago.

Status:
Done
Priority:
No priority
Assignee:
Lola Yang
Category:
GUI (new)
Severity:
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I've been testing and adding tooltips to the Jails Add and Edit forms on my FreeNAS 11-Nightly box. The "RCTL Limits" section of these forms consists of a large number of checkboxes, but reviewing the iocage documentation and RCTL manual page (https://www.freebsd.org/cgi/man.cgi?query=rctl&manpath=FreeBSD+11.1-RELEASE+and+Ports) shows these fields need to be input boxes that accept (at minimum) alphanumeric characters. I reached out to Brandon to confirm if this was correct or in error, and he indicated that 1) Most of these fields need to accept user defined values and 2) RCTL functionality hasn't been added/activated in FreeNAS yet?

Based on this, would it be better to comment out the "RCTL Limits" section of the Jails/Add and Jails/Edit forms until the functionality is present and the fields can accept user defined values?

jails_add_rctllimits.png (170 KB) jails_add_rctllimits.png Timothy Moore II, 03/09/2018 10:30 AM
14905

Related issues

Related to FreeNAS - Bug #29353: (New UI) incorrect option: Jails/Add RCTL Limits/cpusetDone2018-03-08
Related to FreeNAS - Bug #29143: New GUI Jail Properties problemsClosed2018-03-06

History

#1 Updated by Dru Lavigne over 3 years ago

  • Assignee changed from Release Council to Anonymous
  • Target version set to 11.2-RC2

#2 Updated by Anonymous over 3 years ago

  • Assignee changed from Anonymous to Lola Yang

#3 Updated by Timothy Moore II over 3 years ago

  • Related to Bug #29353: (New UI) incorrect option: Jails/Add RCTL Limits/cpuset added

#4 Updated by Lola Yang over 3 years ago

Timothy Moore II wrote:

I've been testing and adding tooltips to the Jails Add and Edit forms on my FreeNAS 11-Nightly box. The "RCTL Limits" section of these forms consists of a large number of checkboxes, but reviewing the iocage documentation and RCTL manual page (https://www.freebsd.org/cgi/man.cgi?query=rctl&manpath=FreeBSD+11.1-RELEASE+and+Ports) shows these fields need to be input boxes that accept (at minimum) alphanumeric characters. I reached out to Brandon to confirm if this was correct or in error, and he indicated that 1) Most of these fields need to accept user defined values and 2) RCTL functionality hasn't been added/activated in FreeNAS yet?

Based on this, would it be better to comment out the "RCTL Limits" section of the Jails/Add and Jails/Edit forms until the functionality is present and the fields can accept user defined values?

Yes, comment out the 'RCTL Limits' section will be better, since Brandon confirmed RCTL functionality hasn't been added/activated in FreeNAS yet.

#5 Updated by Lola Yang over 3 years ago

  • Status changed from Not Started to In Progress
  • Assignee changed from Lola Yang to Anonymous

#6 Updated by Anonymous over 3 years ago

  • Status changed from In Progress to Done
  • Assignee changed from Anonymous to Lola Yang

#7 Updated by Dru Lavigne over 3 years ago

  • Target version changed from 11.2-RC2 to Master - FreeNAS Nightlies
  • Needs Merging changed from Yes to No

#8 Updated by Lola Yang over 3 years ago

  • Related to Bug #29143: New GUI Jail Properties problems added

Also available in: Atom PDF