Project

General

Profile

Bug #29805

Allow /etc/find_alias_for_smtplib.sh to be used by sudoers

Added by Bonnie Follweiler over 1 year ago. Updated about 1 year ago.

Status:
Done
Priority:
No priority
Assignee:
John Hixson
Category:
Console
Target version:
Severity:
Low
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I am currently on FreeNAS-11-MASTER-201803020556
My mini has some error messages, I posted to the developers chat and John advised me to create a bug ticket

FN_Mini.jpeg (285 KB) FN_Mini.jpeg Bonnie Follweiler, 03/13/2018 02:01 PM
Screen Shot 2018-05-03 at 9.00.16 AM.png (914 KB) Screen Shot 2018-05-03 at 9.00.16 AM.png Bonnie Follweiler, 05/03/2018 06:01 AM
15101
17172

Related issues

Copied to FreeNAS - Bug #40636: Allow /etc/find_alias_for_smtplib.sh to be used by sudoersDone

Associated revisions

Revision b962a59e (diff)
Added by John Hixson about 1 year ago

Allow /etc/find_alias_for_smtplib.sh to be used by sudoers

Ticket: #29805

Revision 6c7b4b6d (diff)
Added by John Hixson about 1 year ago

Allow /etc/find_alias_for_smtplib.sh to be used by sudoers

Ticket: #29805
(cherry picked from commit b962a59e75acce42373d7c7cdb90e3ac9b14c0d4)

Revision 9d08e436 (diff)
Added by John Hixson about 1 year ago

Allow /etc/find_alias_for_smtplib.sh to be used by sudoers

Ticket: #29805
(cherry picked from commit b962a59e75acce42373d7c7cdb90e3ac9b14c0d4)

Revision 7063ff5f (diff)
Added by John Hixson 11 months ago

Allow /etc/find_alias_for_smtplib.sh to be used by sudoers

Ticket: #29805
(cherry picked from commit b962a59e75acce42373d7c7cdb90e3ac9b14c0d4)
(cherry picked from commit 6c7b4b6de59e15917c26b796220faf3552d8606f)

(11.1-stable)
Ticket: #40636

History

#2 Updated by Dru Lavigne over 1 year ago

  • Target version set to 11.2-RC2

#3 Updated by John Hixson about 1 year ago

  • Severity set to Low

#5 Updated by Dru Lavigne about 1 year ago

  • Subject changed from Error Messages on the Mini: freenas sudo: root: command not allowed ; TTY=Unknown; PWD=/root; USER=root; COMMAND=/etc/find_alias_for_stmp_lib.sh -i root to Allow /etc/find_alias_for_smtplib.sh to be used by sudoers
  • Status changed from Not Started to In Progress
  • Target version changed from 11.2-RC2 to 11.2-BETA1
  • Needs Doc changed from Yes to No

#6 Updated by Dru Lavigne about 1 year ago

  • Private changed from Yes to No

#7 Updated by John Hixson about 1 year ago

  • Status changed from In Progress to Ready for Testing

#8 Updated by Bonnie Follweiler about 1 year ago

17172

This is still happening (screenshot provided) in FreeNAS-11-MASTER-201805020407

#9 Updated by Dru Lavigne about 1 year ago

  • Status changed from Failed Testing to In Progress

Changing to In Progress as the commit has not been merged yet.

#10 Updated by William Grzybowski about 1 year ago

  • Status changed from In Progress to Ready for Testing

#11 Updated by Dru Lavigne about 1 year ago

  • Needs Merging changed from Yes to No

#12 Avatar?id=55038&size=24x24 Updated by Zackary Welch about 1 year ago

Unable to reproduce. Seems the bug has been fixed and /etc/find_alias_for_smtplib.sh can be run by a sudoer. I cannot reproduce the "command not allowed" error message, but the commands 'cmd -i root' and 'cmd -FCronDaemon -odi -oem -oi -t" do not terminate.

#13 Updated by Dru Lavigne about 1 year ago

  • Status changed from Ready for Testing to Done
  • Needs QA changed from Yes to No

#14 Updated by John Hixson 11 months ago

  • Copied to Bug #40636: Allow /etc/find_alias_for_smtplib.sh to be used by sudoers added

Also available in: Atom PDF