Project

General

Profile

Bug #30127

VM start from GUI not working

Added by Eric McGarr over 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
No priority
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Seen in:
Severity:
Medium
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I have been trying to search for this answer for 5 days. I could not get a new VM to start so I resorted to rebooting the freenas system. the second VM is now running but my first VM is now Stopped and every time I click start it says successful but then still shows stopped and is not running. I have searched /var/log/middlewared.log and /var/log/messages for help with what might be wrong. I cannot find the issue. I have to searching for a shell command to start the VM but I find no answers. the only thing I have to go on is the 3 log errors attached. I have read every single search result containing anything close to this and none of the half solutions I find work. PLEASE HELP ME IM LOSING MY MIND over this. also my clients web sites and primary application are down in the meantime until I can get this VM to start. thanks you

dmesg.PNG (4.24 KB) dmesg.PNG Eric McGarr, 03/17/2018 10:37 AM
guestvmemory.PNG (20.1 KB) guestvmemory.PNG Eric McGarr, 03/17/2018 10:37 AM
promiscuous_mode_enabled.PNG (9.76 KB) promiscuous_mode_enabled.PNG Eric McGarr, 03/17/2018 10:37 AM
rc.conf_error.PNG (7.36 KB) rc.conf_error.PNG Eric McGarr, 03/17/2018 10:37 AM
midclt call vm queryPNG.PNG (56.7 KB) midclt call vm queryPNG.PNG Eric McGarr, 03/17/2018 12:13 PM
freenas VMs.PNG (84.8 KB) freenas VMs.PNG Eric McGarr, 03/17/2018 12:20 PM
htop.PNG (102 KB) htop.PNG Eric McGarr, 03/17/2018 12:36 PM
ls dev vmm.PNG (3.18 KB) ls dev vmm.PNG Eric McGarr, 03/17/2018 12:36 PM
ps aux grep bh.PNG (8.9 KB) ps aux grep bh.PNG Eric McGarr, 03/17/2018 12:36 PM
Screen Shot 2018-03-17 at 1.05.01 PM.png (328 KB) Screen Shot 2018-03-17 at 1.05.01 PM.png Vaibhav Chauhan, 03/17/2018 01:05 PM
15253
15256
15259
15262
15268
15274
15277
15280
15283
15286

Related issues

Related to FreeNAS - Bug #34825: Add UI error message for VM memory usageClosed
Is duplicate of FreeNAS - Bug #26434: Add descriptive error to API when VM fails to startDone

History

#1 Updated by Eric McGarr over 1 year ago

  • File debug-freenas-20180317173716.txz added
  • Private changed from No to Yes

#2 Updated by Eric McGarr over 1 year ago

15253

#3 Updated by Eric McGarr over 1 year ago

15256

#5 Updated by Eric McGarr over 1 year ago

15262

#6 Updated by Vaibhav Chauhan over 1 year ago

hi, please ssh into your freenas and type in midclt call vm.query and paste the output

#7 Updated by Vaibhav Chauhan over 1 year ago

  • Assignee changed from Release Council to Marcelo Araujo

assigning to Marcello as this looking into the logs looks it like something needs to be done on backend side.

#8 Updated by Eric McGarr over 1 year ago

15268

here is the output from midclt call vm.query

#9 Updated by Eric McGarr over 1 year ago

15274

the VM I need to start desperately is the first in the list. Also the 4th one wont start also but the 2 VMs in the middle started fine.

#10 Updated by Vaibhav Chauhan over 1 year ago

ok can you please verify the total memory you have in your freenas system ?

please paste output for

 htop 
ls /dev/vmm 
 ps aux | grep bh 

#11 Updated by Eric McGarr over 1 year ago

15277
15280
15283

#12 Updated by Vaibhav Chauhan over 1 year ago

ok, I may have to guess but I think your freenas is memory constrained, so you may try powering down VM's which are not absolutely necessary and the try powering the first VM which you need the most.

#13 Updated by Eric McGarr over 1 year ago

ok I shutdown Debian2 and Debian3 both had 1024MiB of allocated memory and then my Debian started now. This is good since the first VM is running live applications. However, Im confused because I have 8GB of RAM, how am I being constrained to just 2GB? Thanks for your help and quick responses, I really needed this VM back up before the schools spring break was over. Much appreciation!

#14 Updated by Vaibhav Chauhan over 1 year ago

15286

I am glad reboot helped,:D
freenas new UI is aiming to provide a vm dashboard which may provide you valuable system information.(see attached screenshot)

#15 Updated by Dru Lavigne over 1 year ago

  • Category changed from GUI (new) to Middleware
  • Target version set to 11.2-RC2

Marcelo: if a middleware piece is not needed, please pass back to VB for the new UI.

#16 Updated by Eric McGarr over 1 year ago

Last question, I was able to get 2 VMs running with allocating only 1024 memory to each but why is the other 6GB unusable? I know Freenas uses whatever isnt being allocated but what happend to my other 6GB of RAM. If you could help me understand this I'd much appreciate it? I can install another 8GB stick but will I have use of the full 8GB if I do? stinks I am only able to use 2GB of my RAM.

#17 Updated by Marcelo Araujo over 1 year ago

Dru Lavigne wrote:

Marcelo: if a middleware piece is not needed, please pass back to VB for the new UI.

It needs some rework from my side to return a proper error message up to the UI.

#18 Updated by Marcelo Araujo over 1 year ago

Eric McGarr wrote:

Last question, I was able to get 2 VMs running with allocating only 1024 memory to each but why is the other 6GB unusable? I know Freenas uses whatever isnt being allocated but what happend to my other 6GB of RAM. If you could help me understand this I'd much appreciate it? I can install another 8GB stick but will I have use of the full 8GB if I do? stinks I am only able to use 2GB of my RAM.

Hi,

FreeNAS uses ZFS as its file system, and ZFS heavily uses memory for ARC cache for the most accessed data, any read requests for data in the cache can be served directly from the ARC memory cache instead of hitting the much slower hard drives.

So, usually the system memory allocation is 1GB reserved to OS and the rest dedicated to ARC, ZFS will allocated the memory by demand and also will release it. However when we talk about virtualization, our hypervisor is not aware of ZFS ARC and vice-versa, based on that we try to reserve memory for guests based in some internal algorithms to avoid ZFS ARC cache impact on guest VMs.

What you can do to give more memory for the VM system is to tuning the syscall "vfs.zfs.arc_max" via Tunables menu to have less memory resources available to ZFS.

So if you lower the vfs.zfs.arc_max value to something that you consider will be good for your system, you will be able to launch more guests VMs.

#19 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 1 year ago

  • Category changed from Middleware to OS

#20 Updated by Marcelo Araujo over 1 year ago

  • Severity set to Medium

#21 Updated by Marcelo Araujo about 1 year ago

  • Status changed from Unscreened to Screened
  • Target version changed from 11.2-RC2 to 11.2-U2
  • Parent task set to #34825

#22 Updated by Marcelo Araujo about 1 year ago

  • Parent task deleted (#34825)

#23 Updated by Marcelo Araujo about 1 year ago

  • Related to Bug #34825: Add UI error message for VM memory usage added

#24 Updated by Marcelo Araujo about 1 year ago

  • Status changed from Screened to In Progress

#25 Updated by Marcelo Araujo about 1 year ago

  • Category changed from OS to Middleware
  • Assignee changed from Marcelo Araujo to William Grzybowski

Pass over middleware team.

#26 Updated by Marcelo Araujo about 1 year ago

  • Status changed from In Progress to Unscreened

#27 Updated by William Grzybowski about 1 year ago

  • Status changed from Unscreened to Closed
  • Reason for Closing set to Duplicate Issue

#28 Updated by William Grzybowski about 1 year ago

  • Is duplicate of Bug #26434: Add descriptive error to API when VM fails to start added

#29 Updated by William Grzybowski about 1 year ago

This will be handled as part of #26434

#30 Updated by Dru Lavigne about 1 year ago

  • File deleted (debug-freenas-20180317173716.txz)

#31 Updated by Dru Lavigne about 1 year ago

  • Target version changed from 11.2-U2 to N/A
  • Private changed from Yes to No

Also available in: Atom PDF