Project

General

Profile

Bug #30183

[BUG]WebGUI HTTP -> HTTPS Redirect

Added by D C over 2 years ago. Updated over 2 years ago.

Status:
Done
Priority:
Expected
Assignee:
Erin Clark
Category:
GUI (new)
Seen in:
Severity:
Medium
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Environment:
- new UI
- protocol HTTP+HTTPS
- certificate installed
- System -> General -> WebGUI HTTP -> HTTPS Redirect ENABLED

Bug description:
Although WebGUI HTTP -> HTTPS Redirect is enabled the new UI does not redirect to HTTPS.

Associated revisions

Revision b13549cb (diff)
Added by William Grzybowski over 2 years ago

fix(gui): make sure to have a copy of instance Ticket: #30183

Revision f4760dae (diff)
Added by William Grzybowski over 2 years ago

fix(gui): getting back to legacy UI after changing HTTP settings Ticket: #30183

Revision d6879a27 (diff)
Added by Erin Clark over 2 years ago

Xiiiiiinnnnnnnnnn!!!!!! Ticket: #30183

Revision 5cd1a8c5 (diff)
Added by Erin Clark over 2 years ago

Add afterSubmit to entityForm Ticket: #30183

Revision f7ad3dd3 (diff)
Added by Erin Clark over 2 years ago

Add protocol change detection to restart the webservice and redirect if needed Ticket: #30183

Revision 26437494 (diff)
Added by Erin Clark over 2 years ago

Make port redirecting after webservice reload work. (WIP, this may need a little tweaking still) Ticket: #30183

History

#1 Updated by Dru Lavigne over 2 years ago

  • Assignee changed from Release Council to Erin Clark
  • Target version set to 11.2-RC2

#2 Updated by Erin Clark over 2 years ago

  • Status changed from Unscreened to Not Started

#3 Updated by Erin Clark over 2 years ago

  • Assignee changed from Erin Clark to Xin Tan
  • Priority changed from No priority to Expected

#4 Updated by Dru Lavigne over 2 years ago

  • Assignee changed from Xin Tan to Erin Clark

#5 Updated by Erin Clark over 2 years ago

  • Category changed from GUI (new) to Middleware
  • Assignee changed from Erin Clark to William Grzybowski

It would seem this does reproduce on my box, William says nginx is supposed to handle it so I am passing to him

#6 Updated by William Grzybowski over 2 years ago

  • Category changed from Middleware to GUI (new)
  • Assignee changed from William Grzybowski to Erin Clark

Erin, just look at this, its a tricky one.

The UI will have to manually restart nginx if anything related to UI changed, thats because otherwise user will lose connectivity to the UI without prior notice.

You can do that with

"service.restart" ["http"]

You can expect websocket to reconnect after that. You may also need to redirect the user if he changed from say HTTP to HTTPS.

#7 Updated by William Grzybowski over 2 years ago

  • Target version changed from 11.2-RC2 to 11.2-BETA1

#8 Updated by William Grzybowski over 2 years ago

  • Severity set to Medium

Adding severity because it renders change of HTTP Protocol/ports/etc useless unless one reboot the box

#9 Updated by Erin Clark over 2 years ago

  • Assignee changed from Erin Clark to Lola Yang

#10 Updated by Erin Clark over 2 years ago

  • Status changed from Not Started to In Progress

#11 Updated by Lola Yang over 2 years ago

  • Assignee changed from Lola Yang to Erin Clark

#12 Updated by Erin Clark over 2 years ago

  • Status changed from In Progress to Done

#13 Updated by Dru Lavigne over 2 years ago

  • Target version changed from 11.2-BETA1 to Master - FreeNAS Nightlies
  • Needs Merging changed from Yes to No

Also available in: Atom PDF