Project

General

Profile

Bug #30216

smartd still chokes to death on USB devices in 11.1-U3

Added by Eric Loewenthal over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
No priority
Assignee:
Release Council
Category:
Middleware
Target version:
Seen in:
Severity:
High
Reason for Closing:
Not Applicable
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

The problem fixed in #27935 does not seem to have made it into the 11.1 branch.

This is a rather serious issue, as it prevents smartd from working in any system with an affected USB device (which is a significant majority of USB flash drives, as I understand it).

FWIW, my system complains of:
Mar 19 19:46:22 backup smartd[9512]: Unable to register device /dev/da1 (no Directive -d removable). Exiting.
Even though neither da0 nor da1 are selected for any SMART tasks. They are both Toshiba USB flash drives. Also, smartctl -h does not mention a removable option for the -d flag.


Related issues

Related to FreeNAS - Bug #30354: S.M.A.R.T. fix for devices that report "Unknown USB bridge"Done

History

#1 Updated by Dru Lavigne over 1 year ago

  • Status changed from Unscreened to Closed
  • Target version set to N/A
  • Reason for Closing set to Not Applicable

Correct, as that fix is for the 11.2 branch. Please leave a comment on the related ticket if you test a nightly and the behavior is not fixed. I'll close out this one.

#3 Updated by Eric Loewenthal over 1 year ago

It is fixed in the nightlies, but the seriousness of the problem makes a workaround in the 11.1 branch highly desirable, since SMART monitoring does not work at all on affected systems (SMART tests are not executed either).

#4 Updated by Dru Lavigne over 1 year ago

  • Related to Bug #30354: S.M.A.R.T. fix for devices that report "Unknown USB bridge" added

#5 Updated by Dru Lavigne over 1 year ago

Eric: 11.2-BETA1 will likely be out before the next update in the 11.1 series.

#6 Updated by Harry Weppner over 1 year ago

Dru Lavigne wrote:

Eric: 11.2-BETA1 will likely be out before the next update in the 11.1 series.

Encountered this, too, after upgrading to 11.1-U5 today. Very disappointing as this is a regression from 11.1-U4!

Also available in: Atom PDF