Project

General

Profile

Bug #30660

When trying to View Plugins

Added by Ben Garrett over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
No priority
Assignee:
Release Council
Category:
GUI (new)
Target version:
Seen in:
Severity:
Reason for Closing:
Duplicate
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Error 22:'IOCAGE_SKIP'

Traceback (most recent call last):
File "/usr/local/lib/python3.6/site-packages/middlewared/main.py", line 150, in call_method
result = await self.middleware.call_method(self, message)
File "/usr/local/lib/python3.6/asyncio/coroutines.py", line 128, in throw
return self.gen.throw(type, value, traceback)
File "/usr/local/lib/python3.6/site-packages/middlewared/main.py", line 908, in call_method
return await self._call(message['method'], serviceobj, methodobj, params, app=app)
File "/usr/local/lib/python3.6/asyncio/coroutines.py", line 128, in throw
return self.gen.throw(type, value, traceback)
File "/usr/local/lib/python3.6/site-packages/middlewared/main.py", line 886, in call
return await self.run_in_thread(methodobj, *args)
File "/usr/local/lib/python3.6/asyncio/coroutines.py", line 128, in throw
return self.gen.throw(type, value, traceback)
File "/usr/local/lib/python3.6/site-packages/middlewared/main.py", line 849, in run_in_thread
return await self.run_in_thread_pool(self.
_threadpool, method, *args, **kwargs)
File "/usr/local/lib/python3.6/asyncio/coroutines.py", line 128, in throw
return self.gen.throw(type, value, traceback)
File "/usr/local/lib/python3.6/site-packages/middlewared/main.py", line 845, in run_in_thread_pool
await task
File "/usr/local/lib/python3.6/concurrent/futures/thread.py", line 56, in run
result = self.fn(*self.args, **self.kwargs)
File "/usr/local/lib/python3.6/site-packages/middlewared/schema.py", line 495, in nf
return f(*args, **kwargs)
File "/usr/local/lib/python3.6/site-packages/middlewared/plugins/jail.py", line 178, in list_resource
self.check_dataset_existence() # Make sure our datasets exist.
File "/usr/local/lib/python3.6/site-packages/middlewared/plugins/jail.py", line 140, in check_dataset_existence
IOCCheck()
File "/usr/local/lib/python3.6/site-packages/iocage/lib/ioc_check.py", line 39, in init
"pool")
File "/usr/local/lib/python3.6/site-packages/iocage/lib/ioc_json.py", line 520, in json_get_value
if os.environ["IOCAGE_SKIP"] == "TRUE":
File "/usr/local/lib/python3.6/os.py", line 669, in getitem
raise KeyError(key) from None
KeyError: 'IOCAGE_SKIP'


Related issues

Is duplicate of FreeNAS - Bug #30597: Handle IOCAGE_SKIP gracefully when no pool is activatedDone

History

#1 Updated by Dru Lavigne over 1 year ago

  • Is duplicate of Bug #30597: Handle IOCAGE_SKIP gracefully when no pool is activated added

#2 Updated by Dru Lavigne over 1 year ago

  • Status changed from Unscreened to Closed
  • Target version set to N/A
  • Reason for Closing set to Duplicate

Also available in: Atom PDF