Project

General

Profile

Bug #30687

Fix validation of hostname for FTP Masquerade address

Added by Craig Jones about 1 year ago. Updated 10 months ago.

Status:
Done
Priority:
No priority
Assignee:
Waqar Ahmed
Category:
Middleware
Target version:
Seen in:
Severity:
Low Medium
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Associated revisions

Revision fda0234b (diff)
Added by Waqar Ahmed about 1 year ago

Bug fix (#1090)

Ticket: #30687

History

#1 Updated by Dru Lavigne about 1 year ago

  • Private changed from No to Yes
  • Reason for Blocked set to Need additional information

Craig: please create a debug (System -> Advanced -> Save Debug) after reproducing the error, and attach it to this ticket.

#2 Updated by Craig Jones about 1 year ago

  • File debug-skynet-20180326182425.tgz added

#3 Updated by Dru Lavigne about 1 year ago

  • Category changed from OS to Middleware
  • Target version set to 11.2-RC2

William: for the error shown in https://forums.freenas.org/index.php?threads/ddns-hostname-in-ftp-masquerade-address.62684/, is that a middleware (due to the quote) or a doc issue (this won't be supported)?

#4 Updated by Dru Lavigne about 1 year ago

  • Assignee changed from Release Council to William Grzybowski

#5 Updated by William Grzybowski about 1 year ago

  • Status changed from Unscreened to Not Started
  • Target version changed from 11.2-RC2 to 11.3

#6 Updated by William Grzybowski about 1 year ago

  • Assignee changed from William Grzybowski to Waqar Ahmed

#7 Updated by Waqar Ahmed about 1 year ago

  • Status changed from Not Started to In Progress

#8 Updated by Waqar Ahmed about 1 year ago

  • Reason for Blocked deleted (Need additional information)

#9 Updated by Waqar Ahmed about 1 year ago

  • % Done changed from 0 to 90

#10 Updated by Waqar Ahmed about 1 year ago

  • Status changed from In Progress to Done
  • % Done changed from 90 to 100

#11 Updated by Waqar Ahmed about 1 year ago

  • Status changed from Done to Ready for Testing

#12 Updated by Dru Lavigne about 1 year ago

  • File deleted (debug-skynet-20180326182425.tgz)

#13 Updated by Dru Lavigne about 1 year ago

  • Subject changed from Cannot enter hostname for FTP Masquerade address to Fix validation of hostname for FTP Masquerade address
  • Target version changed from 11.3 to 11.2-BETA1
  • Private changed from Yes to No
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#14 Updated by Bonnie Follweiler 10 months ago

20003

Test passed in FreeNAS 11.2-Internal 12

#15 Updated by Dru Lavigne 10 months ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF