Project

General

Profile

Feature #30840

Bug #30519: Add the ability to "Offline" a disk

Need api/v1.0/storage/disk/{id:number|name:string}/detach (Detaches a disk from a volume). Inorder to offline it.

Added by Peter Southwell over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Expected
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Estimated time:
Severity:
Med High
Reason for Closing:
Behaves as Intended
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

Description

Need api/v1.0/storage/disk/{id:number|name:string}/detach (Detaches a disk from a volume). Inorder to offline it.

In order to support a feature parity of being able to offline a disk.

History

#1 Updated by Dru Lavigne over 2 years ago

  • Target version changed from Master - FreeNAS Nightlies to 11.2-BETA1

#2 Updated by Peter Southwell over 2 years ago

  • Status changed from Not Started to Blocked
  • Target version changed from 11.2-BETA1 to Master - FreeNAS Nightlies
  • % Done changed from 0 to 100

The UI is done.. but need the api

#3 Updated by Peter Southwell over 2 years ago

Code or this (That's waiting for api)... is at origin/feature_30519

#4 Updated by Erin Clark over 2 years ago

  • Priority changed from No priority to Expected
  • Target version changed from Master - FreeNAS Nightlies to 11.2-BETA1

#5 Updated by Peter Southwell over 2 years ago

  • Status changed from Blocked to Not Started

#6 Updated by William Grzybowski over 2 years ago

  • Status changed from Not Started to Closed
  • Reason for Closing set to Behaves as Intended

#7 Updated by William Grzybowski over 2 years ago

  • Target version changed from 11.2-BETA1 to N/A

#8 Updated by William Grzybowski over 2 years ago

Thats the API to detach a disk from a Volume. Let me know if there is anything else missing.

#9 Updated by Peter Southwell over 2 years ago

William Grzybowski wrote:

Thats the API to detach a disk from a Volume. Let me know if there is anything else missing.

Cool William.....

#10 Updated by Peter Southwell over 2 years ago

  • % Done changed from 100 to 90

The old UI just lets the user try.. And the middle wier explains why not.. If your trying to offline a disk that is not in a pool. So.. Im going to allow the menu item. Was my thought.

#11 Updated by Peter Southwell over 2 years ago

This will be under the storage/disks section for disks whose Pool is not "undefined" but instead.. Is an existing pool. Ill assume not cool in the RootPool sense.

#12 Updated by William Grzybowski over 2 years ago

This should be in the Volume Status screen just like old UI, not generic storage/disks section.

Also available in: Atom PDF