Project

General

Profile

Bug #30852

Start iocage jails after volume is unlocked

Added by Marcelo Ruiz about 1 year ago. Updated 10 months ago.

Status:
Done
Priority:
No priority
Assignee:
Brandon Schneider
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I have an iocage jail with boot=on that does not start when the encrypted volume is unlocked.


Related issues

Related to FreeNAS - Bug #35062: Stop iocage jails before locking drive that contains jailsDone

Associated revisions

Revision 0cca1ec6 (diff)
Added by Brandon Schneider about 1 year ago

fix(jail/rc): Run after volume unlock

Ticket: #30852

Revision 994589da (diff)
Added by Brandon Schneider about 1 year ago

fix(jail/rc): Run after volume unlock (#1062)

Ticket: #30852

History

#1 Updated by Marcelo Ruiz about 1 year ago

  • File debug-freenas-20180328012612.txz added
  • Private changed from No to Yes

#2 Updated by Dru Lavigne about 1 year ago

  • Due date set to 04/02/2018
  • Category changed from OS to Middleware
  • Assignee changed from Release Council to Brandon Schneider
  • Target version set to 11.2-RC2
  • Seen in changed from Unspecified to 11.1-U4

#3 Updated by Brandon Schneider about 1 year ago

  • Status changed from Unscreened to Not Started

#4 Updated by Brandon Schneider about 1 year ago

  • Status changed from Not Started to In Progress

#5 Updated by Brandon Schneider about 1 year ago

#6 Updated by Brandon Schneider about 1 year ago

  • Status changed from In Progress to Done
  • Needs Merging changed from Yes to No

#7 Updated by Dru Lavigne about 1 year ago

  • File deleted (debug-freenas-20180328012612.txz)

#8 Updated by Dru Lavigne about 1 year ago

  • Subject changed from iocage jail fails to start after volume is unlocked to Start iocage jails after volume is unlocked
  • Target version changed from 11.2-RC2 to 11.2-BETA1
  • Private changed from Yes to No
  • Needs Doc changed from Yes to No

#9 Updated by Dru Lavigne 12 months ago

  • Status changed from Done to Ready for Testing

#10 Updated by Bonnie Follweiler 10 months ago

  • Severity set to New

Zack Welch is testing this one

#11 Avatar?id=55038&size=24x24 Updated by Zackary Welch 10 months ago

  • Needs QA changed from Yes to No

Talked with Brandon and it seems the issue is jails unable to start after the drive is encrypted. The jails aren't supposed to start automatically on unlock? This seems so, and I was able to start a jail after lock/unlock of an encrypted drive. Passes in 11.2Beta.

#12 Avatar?id=55038&size=24x24 Updated by Zackary Welch 10 months ago

#13 Updated by Bonnie Follweiler 10 months ago

  • Related to Bug #35062: Stop iocage jails before locking drive that contains jails added

#14 Updated by Bonnie Follweiler 10 months ago

  • Status changed from Ready for Testing to Passed Testing

#15 Updated by Dru Lavigne 10 months ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF