Project

General

Profile

Bug #30855

I can't find how to unlock volume with passphrase

Added by Marcelo Ruiz over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Important
Assignee:
Peter Southwell
Category:
GUI (new)
Target version:
Severity:
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I cannot find (so it's not very intuitive) where to unlock a volume typing a passphrase


Related issues

Related to FreeNAS - Bug #31686: There is no option to lock a newly created encrypted volume in the new GUIClosed2018-04-10
Is duplicate of FreeNAS - Bug #31683: There is no place to add a passphrase to an encrypted volumeDone2018-04-10

History

#1 Updated by Marcelo Ruiz over 2 years ago

  • File debug-freenas-20180328012904.txz added
  • Private changed from No to Yes

#2 Updated by Dru Lavigne over 2 years ago

  • Reason for Blocked set to Need additional information

Marcelo: did you follow the instructions in http://doc.freenas.org/11/storage.html#managing-encrypted-volumes? If so, do you get an error when you use the Unlock button?

#3 Updated by Marcelo Ruiz over 2 years ago

  • Subject changed from I can't filnd how to unlock volume with passphrase to I can't find how to unlock volume with passphrase

#4 Updated by Dru Lavigne over 2 years ago

  • File deleted (debug-freenas-20180328012904.txz)

#5 Updated by Dru Lavigne over 2 years ago

  • Status changed from Unscreened to Closed
  • Target version set to N/A
  • Private changed from Yes to No

#6 Updated by Marcelo Ruiz over 2 years ago

Quote

Marcelo: did you follow the instructions in http://doc.freenas.org/11/storage.html#managing-encrypted-volumes? If so, do you get an error when you use the Unlock button?

Hi Dru,
The instructions you're pointing to refer to the old GUI. The category description of the bug says GUI (new). I guess I thought this was the new GUI (currently in Beta).
I can manage the encrpyted volumes with no problem using the 'Old' UI.
Marcelo.

#7 Updated by Dru Lavigne over 2 years ago

  • Status changed from Closed to Not Started
  • Assignee changed from Release Council to Erin Clark
  • Target version changed from N/A to 11.2-RC2
  • Reason for Blocked deleted (Need additional information)

#8 Updated by Erin Clark over 2 years ago

  • Assignee changed from Erin Clark to Peter Southwell

#9 Updated by Peter Southwell over 2 years ago

  • Status changed from Not Started to Closed
  • Priority changed from No priority to Important

So here's how you do it from start to finish in the new UI. And Ive tested this bunches so feel confident about it working :) Although.. If you've found a case Id like to know ASAP and will fix it.

1) Go to Storage/Pools

Buttons at the top create a new Pool
2) Up comes Pool Manager (volume manager). Type the name you'd like it to be... Say
"TEST_ENCR"
Select the "Encrypted" check box.
Use the List Transer Box.. To select disks and in the right list box when you transfer them there.
Select stripe/mirror, etc..
Push Save... It'll make you download your geli.key (which you should keep when un encrypting volumes).. but it's not used in this example.

3) This takes you to Volumes/Pools List. You SHOULd see your volume there and it'll have a picture of a lock on it.. To indicate encrypted.

4) Under the Lock Menu when you expand your pools expansion panel... Create A Passphrase.

5) Now that you have a passphrase you can Go to same menu.. And "Lock" appears.. This lets you lock the volume.

6) NOW that you've locked it.. (the status will change and you'll see LOCKED)... Go to menu again.. Now "Lock" is goone.. Because you can't re-lock it.. And instead a new menu item is there "Unlock"

7) Push unlock.. You'll go to a enterpassphrase form. Enter is.. And proceed by pushing "Unlock" button.

That's it.. You should see it redirets back to the Pool/Volumes List page.. And your Volume should now be unlocked.

:)

Hope that helps. And happy to re-visit this if you found an a bug that has a specific produce path.

#10 Updated by Dru Lavigne over 2 years ago

  • Related to Bug #31686: There is no option to lock a newly created encrypted volume in the new GUI added

#11 Updated by Dru Lavigne over 2 years ago

  • Is duplicate of Bug #31683: There is no place to add a passphrase to an encrypted volume added

#12 Updated by Dru Lavigne over 2 years ago

  • Target version changed from 11.2-RC2 to N/A
  • Seen in changed from Unspecified to Master - FreeNAS Nightlies
  • Reason for Closing set to Duplicate Issue

Bonnie has confirmed that this is resolved by the duplicated ticket.

Also available in: Atom PDF