Project

General

Profile

Bug #30873

iocage jail storage giving "Resource Deadlock Avoided" error upon jail restart

Added by Jerry Harrison over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
No priority
Assignee:
Brandon Schneider
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Need additional information from Author
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Jail created using 11.1-RELEASE
Jail FSTAB to mount two storage locations...
-----------------------------------------------------------------------------------------------------+ | INDEX | FSTAB ENTRY |
=======+================================================================================================ | 0 | /mnt/zpool1/iocagedata/nextcloud /mnt/iocage/jails/nextcloud/root/mnt/nextdata nullfs rw 0 0 |
-----------------------------------------------------------------------------------------------------+ | 1 | /mnt/zpool1/iocagedata/jailscripts /mnt/iocage/jails/nextcloud/root/mnt/scripts nullfs rwx 0 0 |
-----------------------------------------------------------------------------------------------------+
jail starts and operates normally, with both storage locations available.

Upon Jail restart, restart fails, and error is:
  • Stopping nextcloud
    + Running prestop OK
    + Stopping services OK
    + Removing jail process OK
    + Running poststop OK
  • Starting nextcloud
    + Start FAILED
    mount_nullfs: /mnt/iocage/jails/nextcloud/root/mnt/scripts: Resource deadlock avoided
    jail: /sbin/mount -t nullfs -o rwx /mnt/zpool1/iocagedata/jailscripts /mnt/iocage/jails/nextcloud/root/mnt/scripts: failed

Reboot of server allows jail to start normally.
Changing of the FSTAB table for the jail to a different source directory (without a reboot of the server) allows jail to start normally.

History

#1 Updated by Dru Lavigne over 1 year ago

  • Assignee changed from Release Council to Brandon Schneider
  • Target version set to 11.2-RC2
  • Reason for Blocked set to Need verification

Brandon: do you know if the iocage version that will ship in 11.2 addresses this?

#2 Updated by Brandon Schneider over 1 year ago

  • Status changed from Unscreened to Closed
  • Reason for Closing set to Behaves as Intended

This is nullfs avoiding a deadlock of the system by doing a duplicate mount. You must have some process that is not dying gracefully and holding onto the mounts inside the jail. iocage can't solve that :)

#3 Updated by Dru Lavigne over 1 year ago

  • Target version changed from 11.2-RC2 to N/A

#4 Updated by Jerry Harrison over 1 year ago

The only processes running are the ones created by the creation of the jail.

#5 Updated by Dru Lavigne over 1 year ago

  • Status changed from Closed to Not Started
  • Private changed from No to Yes
  • Reason for Closing deleted (Behaves as Intended)

Jerry: please reproduce the issue then create a debug (System -> Advanced -> Save Debug) and attach it to this ticket.

#6 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 1 year ago

  • Category changed from OS to Middleware

#7 Updated by Dru Lavigne over 1 year ago

  • Status changed from Not Started to Blocked
  • Target version changed from N/A to 11.2-RC2

#8 Updated by Dru Lavigne over 1 year ago

  • Status changed from Blocked to Closed
  • Target version changed from 11.2-RC2 to N/A
  • Private changed from Yes to No
  • Reason for Blocked changed from Need verification to Need additional information from Author

Also available in: Atom PDF