Project

General

Profile

Bug #30969

Merge fix for detaching a degraded or offlined disk from a pool

Added by David Robinson over 1 year ago. Updated about 1 year ago.

Status:
Done
Priority:
No priority
Assignee:
Vladimir Vinogradenko
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Request Method: POST
Request URL: http://192.168.1.53/system/bootenv/pool/detach/1920695084782375676/
Software Version: FreeNAS-11.1-U4 (89e3d93bc)
Exception Type: ClientException
Exception Value:
[EINVAL] Failed to find vdev for 1920695084782375676
Exception Location: /usr/local/lib/python3.6/site-packages/middlewared/client/client.py in call, line 421
Server time: Thu, 29 Mar 2018 14:26:42 -0400
Traceback

Environment:

Software Version: FreeNAS-11.1-U4 (89e3d93bc)
Request Method: POST
Request URL: http://192.168.1.53/system/bootenv/pool/detach/1920695084782375676/

Traceback:
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/exception.py" in inner
42. response = get_response(request)
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/base.py" in _legacy_get_response
249. response = self._get_response(request)
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/base.py" in _get_response
178. response = middleware_method(request, callback, callback_args, callback_kwargs)
File "./freenasUI/freeadmin/middleware.py" in process_view
162. return login_required(view_func)(request, *view_args, **view_kwargs)
File "/usr/local/lib/python3.6/site-packages/django/contrib/auth/decorators.py" in _wrapped_view
23. return view_func(request, *args, **kwargs)
File "./freenasUI/system/views.py" in bootenv_pool_detach
543. c.call('boot.detach', label)
File "./freenasUI/system/views.py" in bootenv_pool_detach
543. c.call('boot.detach', label)
File "/usr/local/lib/python3.6/site-packages/middlewared/client/client.py" in call
421. raise ClientException(c.error, c.errno, c.trace, c.extra)

Exception Type: ClientException at /system/bootenv/pool/detach/1920695084782375676/
Exception Value: [EINVAL] Failed to find vdev for 1920695084782375676

Request information
GET
No GET data

POST
Variable Value
__form_id 'form_str'
FILES
No FILES data

COOKIES
Variable Value
csrftoken '********'
sessionid 'gjpea7tfam4p3fyfg4bnxkvkeppg83wb'
fntreeSaveStateCookie 'root'
META
Variable Value

OfflineDiskInMirror-2018-06-28.png (22.7 KB) OfflineDiskInMirror-2018-06-28.png Michael Reynolds, 06/28/2018 09:18 AM
19823

History

#1 Updated by Dru Lavigne over 1 year ago

  • Private changed from No to Yes

David: please attach a debug (System -> Advanced -> Save Debug).

#2 Updated by David Robinson over 1 year ago

  • File debug-freenas-20180329183125.txz added

#3 Updated by Dru Lavigne over 1 year ago

  • Assignee changed from Release Council to William Grzybowski
  • Target version set to 11.2-RC2
  • Seen in changed from Unspecified to 11.1-U4

#4 Updated by David Robinson over 1 year ago

  • File debug-freenas-20180329143428.tgz added
  • Seen in changed from 11.1-U4 to Unspecified

#5 Updated by Dru Lavigne over 1 year ago

  • Seen in changed from Unspecified to 11.1-U4

#6 Updated by William Grzybowski over 1 year ago

  • Assignee changed from William Grzybowski to Vladimir Vinogradenko

Vladimir, pretty sure its the same ticket you were working on the other day. Can you mark this as a duplicate, please?

#7 Updated by David Robinson over 1 year ago

  • Reason for Closing set to Duplicate

William Grzybowski wrote:

Vladimir, pretty sure its the same ticket you were working on the other day. Can you mark this as a duplicate, please?

#8 Updated by Vladimir Vinogradenko over 1 year ago

William, actually, this is a similar but separate issue, I'll look this up tomorrow

#9 Updated by Vladimir Vinogradenko over 1 year ago

  • Status changed from Unscreened to Not Started

This is a duplicate of https://redmine.ixsystems.com/issues/27342 that was not merged to stable branch

Stable PR here: https://github.com/freenas/freenas/pull/1048

#10 Updated by Vladimir Vinogradenko over 1 year ago

  • Status changed from Not Started to Closed

#11 Updated by Dru Lavigne over 1 year ago

  • File deleted (debug-freenas-20180329183125.txz)

#12 Updated by Dru Lavigne over 1 year ago

  • File deleted (debug-freenas-20180329143428.tgz)

#13 Updated by Dru Lavigne over 1 year ago

  • Subject changed from Can not replace or detach failed or bad mirroed drive to Merge fix for detaching a degraded or offlined disk from a pool
  • Status changed from Closed to Done
  • Target version changed from 11.2-RC2 to 11.2-BETA1
  • Private changed from Yes to No
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#14 Updated by Dru Lavigne about 1 year ago

  • Status changed from Done to Ready for Testing

#15 Updated by Michael Reynolds about 1 year ago

  • File DetachDegraded-2018-06-27.png added
  • File DetachDegradedLegacy-2018-06-27.png added
  • Status changed from Ready for Testing to Passed Testing
  • Severity set to New
  • Needs QA changed from Yes to No

No errors detaching a degraded pool in WebUI or Legacy

checked dmesg and /var/log/messages

#16 Updated by William Grzybowski about 1 year ago

The fix was about detaching a disk from a pool (freenas-boot pool), not detaching a whole pool.

#17 Updated by Michael Reynolds about 1 year ago

oops got this one backwards, I detached a degraded pool, not a degraded disk from a pool
will re-test tomorrow

#18 Updated by Dru Lavigne about 1 year ago

  • Status changed from Passed Testing to Ready for Testing
  • Needs QA changed from No to Yes

#19 Updated by Michael Reynolds about 1 year ago

  • File deleted (DetachDegraded-2018-06-27.png)

#20 Updated by Michael Reynolds about 1 year ago

  • File deleted (DetachDegradedLegacy-2018-06-27.png)

#21 Updated by Michael Reynolds about 1 year ago

19823

Started with a Pool that has 2 disks in a mirror

Went to Storage:Pools -> Gear -> Status
3 dots on ada2p2 -> Offline disk

The disk offlines properly (no tracebacks like in this ticket) and the Pool is marked as degraded

#22 Updated by Dru Lavigne about 1 year ago

  • Status changed from Passed Testing to Done
  • Reason for Closing deleted (Duplicate)

Also available in: Atom PDF