Project

General

Profile

Bug #31014

Fix middleware client not working in Microsoft Edge due to middlewareTokenUrl being undefined

Added by Matt Sturtz about 1 year ago. Updated 10 months ago.

Status:
Done
Priority:
Important
Assignee:
Vladimir Vinogradenko
Category:
Middleware
Target version:
Seen in:
Severity:
Medium
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I created a new (free, if that matters) Backblaze account. I enabled B2, and created a bucket. I created an application key.

In FreeNAS I added the credentials as a Backblaze B2, this appeared to work (no errors).

I attempted to create a cloud-sync task, I added a description, verified Direction is push (default), and selected the Backblaze credential. At this point a spinner appears below that pulldown, and spins forever.

Associated revisions

Revision c9716486 (diff)
Added by Vladimir Vinogradenko about 1 year ago

fix(oldgui): Fix middleware client not working in Microsoft Edge due to
middlewareTokenUrl being undefined

Ticket: #31014

History

#1 Updated by Dru Lavigne about 1 year ago

  • Private changed from No to Yes

Matt, please attach a debug (System -> Advanced -> Save Debug) after reproducing the issue and attach it to this ticket.

#2 Updated by Matt Sturtz about 1 year ago

Dru Lavigne wrote:

Matt, please attach a debug (System -> Advanced -> Save Debug) after reproducing the issue and attach it to this ticket.

Further info. I tried to save the debug, that just spins (actually scrolls) for a long time as well. I started over with Firefox (was MS Edge/Win10). The original problem is not present when using FF, the UI works as intended. All other config/etc has been done using Edge, without any issues, so it didn't occur to me that this might be a browser issue.

#3 Updated by Dru Lavigne about 1 year ago

Matt: can you create the debug in Firefox? We'll still need one to diagnose what Edge doesn't like.

#4 Updated by Matt Sturtz about 1 year ago

  • File debug-freenas-20180401154016.tgz added

#5 Updated by Dru Lavigne about 1 year ago

  • Assignee changed from Release Council to William Grzybowski
  • Target version set to 11.2-RC2

#6 Updated by William Grzybowski about 1 year ago

  • Assignee changed from William Grzybowski to Vladimir Vinogradenko

Vladimir, didnt you fix an issue recently to show errors on that stage?

#7 Updated by Vladimir Vinogradenko about 1 year ago

  • Category changed from Middleware to OS
  • Status changed from Unscreened to Screened
  • Priority changed from No priority to Important

#8 Updated by William Grzybowski about 1 year ago

  • Category changed from OS to Middleware

#9 Updated by Vladimir Vinogradenko about 1 year ago

  • Severity set to Medium

#10 Updated by Vladimir Vinogradenko about 1 year ago

  • Status changed from Screened to Ready for Testing

#11 Updated by Dru Lavigne about 1 year ago

  • File deleted (debug-freenas-20180401154016.tgz)

#12 Updated by Dru Lavigne about 1 year ago

  • Subject changed from Cloud-sync to Backblaze -- add task does not work to Fix middleware client not working in Microsoft Edge due to middlewareTokenUrl being undefined
  • Target version changed from 11.2-RC2 to 11.2-BETA1
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#13 Updated by Dru Lavigne about 1 year ago

  • Private changed from Yes to No

#14 Avatar?id=55038&size=24x24 Updated by Zackary Welch 10 months ago

Currently working on testing this.

#15 Avatar?id=55038&size=24x24 Updated by Zackary Welch 10 months ago

  • Status changed from Ready for Testing to Passed Testing
  • Needs QA changed from Yes to No

I cannot reproduce this on Microsoft Edge, so this seems fixed. I found an issue with saving Cloud Sync Tasks in the process, but it isn't related to this ticket.

#16 Updated by Dru Lavigne 10 months ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF