Project

General

Profile

Bug #31083

Fix traceback when importing a non-encrypted pool

Added by Peter Southwell over 1 year ago. Updated about 1 year ago.

Status:
Done
Priority:
Critical
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Severity:
High
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No
Tags:

Description

Marked HIGH sense it's a backward feature that's in issue and broke in both UIs. it was workign previously for sure.

When importing volume.

Request Method: POST
Request URL: http://10.0.0.35/legacy/storage/auto-import/
Software Version: FreeNAS-11-MASTER-201804010352 (a71506d)
Exception Type: AttributeError
Exception Value:
'NoneType' object has no attribute 'seek'
Exception Location: ./freenasUI/storage/forms.py in done, line 889
Server time: Sun, 1 Apr 2018 11:43:25 -0700
Traceback

Environment:

Software Version: FreeNAS-11-MASTER-201804010352 (a71506d)
Request Method: POST
Request URL: http://10.0.0.35/legacy/storage/auto-import/

Traceback:
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/exception.py" in inner
42. response = get_response(request)
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/base.py" in _legacy_get_response
249. response = self._get_response(request)
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/base.py" in _get_response
178. response = middleware_method(request, callback, callback_args, callback_kwargs)
File "./freenasUI/freeadmin/middleware.py" in process_view
163. return login_required(view_func)(request, *view_args, **view_kwargs)
File "/usr/local/lib/python3.6/site-packages/django/contrib/auth/decorators.py" in _wrapped_view
23. return view_func(request, *args, **kwargs)
File "/usr/local/lib/python3.6/site-packages/django/views/generic/base.py" in view
68. return self.dispatch(request, *args, **kwargs)
File "/usr/local/lib/python3.6/site-packages/formtools/wizard/views.py" in dispatch
237. response = super(WizardView, self).dispatch(request, *args, **kwargs)
File "/usr/local/lib/python3.6/site-packages/django/views/generic/base.py" in dispatch
88. return handler(request, *args, **kwargs)
File "/usr/local/lib/python3.6/site-packages/formtools/wizard/views.py" in post
300. return self.render_done(form, **kwargs)
File "/usr/local/lib/python3.6/site-packages/formtools/wizard/views.py" in render_done
357. **kwargs)
File "./freenasUI/storage/forms.py" in done
889. key.seek(0)

Exception Type: AttributeError at /legacy/storage/auto-import/
Exception Value: 'NoneType' object has no attribute 'seek'

Request information
GET
No GET data

POST
Variable Value
auto_import_wizard-current_step '2'
2-__all__ ''
2-volume_id 'BLAH|4659935612274287827'
__form_id 'dijit_form_Form_1'
FILES
No FILES data

COOKIES
Variable Value
fntreeSaveStateCookie 'root%2Croot%2F62%2Croot%2F62%2F63'
csrftoken '********'
sessionid 'gadoxri0utt8xaxvjtgvn3h7nfjcr70n'
META
Variable Value

Same type of error in new UI as well.

screenshot.png (265 KB) screenshot.png Peter Southwell, 04/01/2018 06:45 PM
15951

Associated revisions

Revision 6354b060 (diff)
Added by William Grzybowski over 1 year ago

fix(gui): import non-encrypted volume/pool

Ticket: #31083

Revision 55928c7d (diff)
Added by William Grzybowski over 1 year ago

fix(gui): import non-encrypted volume/pool

Ticket: #31083

History

#1 Updated by Dru Lavigne over 1 year ago

  • Target version set to 11.2-RC2

#2 Updated by William Grzybowski over 1 year ago

  • Status changed from Not Started to In Progress
  • Target version changed from 11.2-RC2 to 11.2-BETA1

#3 Updated by Dru Lavigne over 1 year ago

  • Subject changed from Bug in import Both old and new UI in the nightlyies. to Fix traceback when importing a non-encrypted pool
  • Needs Doc changed from Yes to No

#4 Updated by William Grzybowski over 1 year ago

  • Status changed from In Progress to Done

#5 Updated by Dru Lavigne over 1 year ago

  • Needs Merging changed from Yes to No

#6 Updated by Dru Lavigne about 1 year ago

  • Status changed from Done to Ready for Testing

#7 Updated by Ethan Large about 1 year ago

  • Status changed from Ready for Testing to Passed Testing
  • Needs QA changed from Yes to No

Now working as intended.

#8 Updated by Dru Lavigne about 1 year ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF