Project

General

Profile

Bug #31095

(New UI) Can't navigate away from Storage/Pools/Edit Permissions

Added by Timothy Moore II over 3 years ago. Updated over 3 years ago.

Status:
Done
Priority:
No priority
Assignee:
-
Category:
GUI (new)
Severity:
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I'm testing/comparing features in the old and new UI on my system updated to the latest FreeNAS-11-Nightly version. I navigated to Storage/Pools and clicked "Edit Permissions" for my "tank/iocage" dataset. The proper form opens and everything looks ok. When I clicked "Cancel" or otherwise try to navigate away from this page, the browser (Firefox) stalls and won't display any other UI window. The only way to sidestep the issue is to delete and manually type the address of another UI screen in my address bar.

Associated revisions

Revision 4c5ed2b3 (diff)
Added by Erin Clark over 3 years ago

Prevent editing permissions of iocage dataset Ticket: #31095

History

#1 Updated by Anonymous over 3 years ago

  • Assignee changed from Anonymous to Lola Yang

After discussion with Brandon, the iocage dataset's permissions should not be editable so I am hiding the edit action from it and its children

https://github.com/freenas/webui/pull/596

#2 Updated by Anonymous over 3 years ago

  • Status changed from Not Started to In Progress

#3 Updated by Lola Yang over 3 years ago

  • Status changed from In Progress to Done
  • Assignee changed from Lola Yang to Anonymous

#4 Updated by Dru Lavigne over 3 years ago

  • Target version changed from 11.2-RC2 to Master - FreeNAS Nightlies
  • Needs Merging changed from Yes to No

Also available in: Atom PDF