Project

General

Profile

Bug #31206

Pool creation allows multiple vdev types to be checked

Added by Joe Maloney over 3 years ago. Updated over 3 years ago.

Status:
Done
Priority:
Important
Assignee:
-
Category:
GUI (new)
Severity:
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Attached is a screenshot showing how to reproduce the issue.

Create a new pool with at least 1 disk for data vdevs.
Add a cache device.
Check the box next to "Cache vdev" and check an available disk.
Click the > next to Cache vdev and the disk adds fine.
Add a log vdev.
Check the box next to log vdev, and an available disk.
Click the > next to log vdev and the disk will be added to Data vdevs because we allow both Cache vDev, and log vDev to be checked at the same time.

The result is that sometimes the cache vdev will be added to the data vdev. To summarize unchecking Cache vdev before trying to add a device to log vdev will fix the issue. I think the issue I see is that we allow multiple vdev types to be selected at the same time. I think we should only allow one vdev type to be checked a at time. Ideally we wouldn't need a checkbox next to vdev type at all. We could simply check the available disk(s), and click the > next to the vdev type we want to move the available disk too.

Associated revisions

Revision 09fd3d93 (diff)
Added by Erin Clark over 3 years ago

Tweaks to volume manager, hiding checkbox for vdevs since it is confusing and screwy with multiple vdevs, minor css tweaks and require a name Ticket: #31206

History

#1 Updated by Dru Lavigne over 3 years ago

  • Category set to GUI (new)
  • Assignee changed from Release Council to Anonymous
  • Target version set to 11.2-RC2

#2 Updated by Anonymous over 3 years ago

  • Assignee changed from Anonymous to Lola Yang

#3 Updated by Anonymous over 3 years ago

  • Status changed from Not Started to In Progress
  • Priority changed from No priority to Important

#4 Updated by Lola Yang over 3 years ago

  • Status changed from In Progress to Done
  • Assignee changed from Lola Yang to Anonymous

#5 Updated by Dru Lavigne over 3 years ago

  • Target version changed from 11.2-RC2 to Master - FreeNAS Nightlies
  • Needs Merging changed from Yes to No

Also available in: Atom PDF