Project

General

Profile

Bug #31284

After Upgrade and reboots I get an email saying my pool was in an unknown state but, in the GUI, it's healthy

Added by Bonnie Follweiler over 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Important
Assignee:
Vladimir Vinogradenko
Category:
Middleware
Target version:
Severity:
High
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I upgraded to FreeNAS-11-MASTER-201804040352 rebooted and an email was sent that said the volume was in an Unknown state but in the GUI the volume is healthy. (screenshots provided)
Gone alerts:
  • The volume tanka state is UNKNOWN:

and

New alerts:
  • The volume tanka state is UNKNOWN:
Alerts:
  • The volume tanka state is UNKNOWN:
    Screenshots provided

Related issues

Has duplicate FreeNAS - Bug #32862: Upgraded a FreeNAS Nightlies VM and I am getting a " CRITICAL: April 30, 2018, 7:15 p.m. - The volume new_tank state is UNKNOWN: " but the GUI says the volume is healthyClosed2018-04-30
Is duplicate of FreeNAS - Bug #33300: Wait for system to fully boot before running alertsDone

History

#1 Updated by Bonnie Follweiler over 1 year ago

  • Subject changed from I got an email saying my pool was in an unknown state bit, in the GUI, it's healthy to After Upgrade and reboots I get an email saying my pool was in an unknown state but, in the GUI, it's healthy

#2 Updated by William Grzybowski over 1 year ago

  • Assignee changed from William Grzybowski to Vladimir Vinogradenko
  • Target version set to 11.2-RC2

#3 Updated by Vladimir Vinogradenko over 1 year ago

  • Priority changed from No priority to Important

#4 Updated by Vladimir Vinogradenko over 1 year ago

  • Severity set to High

I've had this myself (and ignored it), now I can't repeat it. I think pool is just not ready when middlewared starts and begins to gather alerts. Will check soon.

#6 Updated by Dru Lavigne about 1 year ago

  • Has duplicate Bug #32862: Upgraded a FreeNAS Nightlies VM and I am getting a " CRITICAL: April 30, 2018, 7:15 p.m. - The volume new_tank state is UNKNOWN: " but the GUI says the volume is healthy added

#8 Updated by Vladimir Vinogradenko about 1 year ago

  • Status changed from Not Started to Closed
  • Reason for Closing set to Duplicate Issue

#9 Updated by Vladimir Vinogradenko about 1 year ago

  • Is duplicate of Bug #33300: Wait for system to fully boot before running alerts added

#10 Updated by Dru Lavigne about 1 year ago

  • Target version changed from 11.2-RC2 to N/A

Also available in: Atom PDF