Project

General

Profile

Feature #313

GUI: nfs port range (portmapper)

Added by Matthew Whitworth over 9 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Nice to have
Assignee:
William Grzybowski
Category:
GUI (new)
Target version:
Estimated time:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

Description

At the moment, it's currently not possible to specify the ports that various NFS services should use, either via the GUI or via the standard /etc/nfs.conf.

Being able to specify this would be useful for firewall rules etc.

History

#1 Updated by Anonymous about 9 years ago

nfs.conf isn't a standard means of doing things.

That aside, you can do this today via the directions described here: http://forums.freebsd.org/showthread.php?t=17984 . The problem is that this doesn't really fit into the way that [[FreeNAS]] is designed today, as you rightfully noted in your post above (configuration details are plugged into SQL, not just straight rc.conf). You can hack things and get them to work, but I'd rather not recommend the method I have in mind.

Can you please describe your machine topology (the [[FreeNAS]] box, firewall, etc and how they are glued together), so I can get an idea of what is trying to be achieved here?

Thanks!

#2 Updated by William Grzybowski almost 7 years ago

  • Status changed from Unscreened to Resolved
  • Assignee set to William Grzybowski
  • Target version set to 9.1.0-RELEASE

As of 9.1.X it is possible to set the NFS bind ports in Services -> NFS.

#3 Updated by Jordan Hubbard over 6 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF