Project

General

Profile

Bug #31419

(New UI) Jails/Add: Update form to have automatically configured options displayed properly

Added by Timothy Moore II about 2 years ago. Updated almost 2 years ago.

Status:
Done
Priority:
No priority
Assignee:
Lola Yang
Category:
GUI (new)
Severity:
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I'm testing the new UI with a FreeNAS system updated to the latest FreeNAS-11-Nightly version. I navigated to Jails/Add, and created "test" by filling in only the Name and Release options. Clicking "Save" created the new jail. Next, I chose "Edit" for "test" and scrolled through the available options (which appears to be an exact duplicate of the Jails/Add form). Many of the fields, checkboxes, and drop-down menus have substantive selections that I didn't choose in the jail creation process. Could the Jails/Add form be updated to reflect the options that iocage configures by default?

jails_new_basic.png (84 KB) jails_new_basic.png Timothy Moore II, 04/06/2018 06:31 AM
jails_edit_basic.png (89.3 KB) jails_edit_basic.png Timothy Moore II, 04/06/2018 06:31 AM
16209
16212

Related issues

Related to FreeNAS - Feature #31731: Extend jail.query to allow a jail identifierDone
Related to FreeNAS - Bug #32067: Fix error in jail.create callDone2018-04-13

History

#1 Updated by Erin Clark about 2 years ago

  • Assignee changed from Erin Clark to Lola Yang

#2 Updated by Lola Yang almost 2 years ago

  • Related to Feature #31731: Extend jail.query to allow a jail identifier added

#3 Updated by Lola Yang almost 2 years ago

  • Related to Bug #32067: Fix error in jail.create call added

#4 Updated by Lola Yang almost 2 years ago

  • Status changed from Unscreened to In Progress
  • Assignee changed from Lola Yang to Erin Clark

#5 Updated by Dru Lavigne almost 2 years ago

  • Status changed from In Progress to Done
  • Assignee changed from Erin Clark to Lola Yang
  • Target version changed from 11.2-RC2 to Master - FreeNAS Nightlies
  • Needs Merging changed from Yes to No

Also available in: Atom PDF