Project

General

Profile

Bug #31431

(New UI) Jails: Missing option to create a jail from a template

Added by Timothy Moore II over 3 years ago. Updated over 3 years ago.

Status:
Done
Priority:
No priority
Assignee:
Lola Yang
Category:
GUI (new)
Severity:
Reason for Closing:
Not Applicable
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I'm testing the new UI with my FreeNAS system installed with the latest FreeNAS-11-Nightly version.
I navigated to the "Jails" page, created a new jail called "test", and edited it to set it as a "template" (Jails/Edit/Custom Properties: "template" checkbox). At this point, both iocage and the old ui supports creating a new jail from this custom template jail, but I don't see any options, flags, or any UI element to use this template to create a new jail. Maybe add a "Create jail from template" action to a template's "More Actions" (vertical dots) button and remove the start/stop buttons?

iocage template documentation: http://iocage.readthedocs.io/en/latest/templates.html

newui_jails_templates.png (69.3 KB) newui_jails_templates.png Timothy Moore II, 04/06/2018 08:51 AM
oldui_jails_templates.png (55.2 KB) oldui_jails_templates.png Timothy Moore II, 04/06/2018 08:51 AM
iocage_templates.png (136 KB) iocage_templates.png Timothy Moore II, 04/06/2018 08:51 AM
16221
16224
16227

Related issues

Related to FreeNAS - Bug #31551: (New UI) Jails/Edit: Cannot convert template jail back to a regular jailClosed2018-04-09
Is duplicate of FreeNAS - Bug #29008: I don't see Jail Template in the New UI. Closed2018-03-01

History

#1 Updated by Anonymous over 3 years ago

  • Assignee changed from Anonymous to Lola Yang

#2 Updated by Lola Yang over 3 years ago

  • Status changed from Unscreened to Closed
  • Reason for Closing set to Not Applicable

Jail template is not applicable. And Brandon confirmed we don't need it for now.

#3 Updated by Lola Yang over 3 years ago

  • Related to Bug #29008: I don't see Jail Template in the New UI. added

#4 Updated by Lola Yang over 3 years ago

  • Related to deleted (Bug #29008: I don't see Jail Template in the New UI. )

#5 Updated by Lola Yang over 3 years ago

  • Is duplicate of Bug #29008: I don't see Jail Template in the New UI. added

#6 Updated by Dru Lavigne over 3 years ago

  • Target version changed from 11.2-RC2 to N/A

#7 Updated by Timothy Moore II over 3 years ago

I would recommend removing the "template" checkbox from the Custom Properties section of the Jail/Add and Jail/Edit forms.

#8 Updated by Dru Lavigne over 3 years ago

  • Status changed from Closed to Not Started
  • Target version changed from N/A to 11.2-BETA1

#9 Updated by Lola Yang over 3 years ago

  • Status changed from Not Started to In Progress
  • Assignee changed from Lola Yang to Anonymous

#10 Updated by Lola Yang over 3 years ago

  • Related to Bug #31551: (New UI) Jails/Edit: Cannot convert template jail back to a regular jail added

#11 Updated by Dru Lavigne over 3 years ago

  • Status changed from In Progress to Done
  • Assignee changed from Anonymous to Lola Yang
  • Target version changed from 11.2-BETA1 to Master - FreeNAS Nightlies
  • Needs Merging changed from Yes to No

Also available in: Atom PDF